Mavericks & WPA Wifi problems

Discussion in 'OS X Mavericks (10.9)' started by meme291194, Oct 23, 2013.

  1. meme291194 macrumors newbie

    Joined:
    Oct 23, 2013
    #1
    Hi,

    So I have a macbook pro and I just installed mavericks.

    Before I installed mavericks, I was able to connect to my dorm Wifi which was WPA (I don't know what that means). After installing mavericks, the WPA wifi option doesn't show up on the list of networks. Other networks do but not the WPA network that I need to connect to. A friend with a macbook pro without mavericks was able to see and connect to the WPA dorm wifi but I can't. I don't know what to do!
     
  2. DrFreeman macrumors member

    Joined:
    Apr 9, 2010
    #2
    Solution

    This worked for me

    - click on the wifi icon
    - click on Join Other Networks
    - type your network name, e.g. John-WPA
    - choose security setting, usually WPA2 Enterprise but check with your ICT
    - then put in your user name and password and all should work.


    Note that you would still not see the network, although you would be connected to it and all would work fine!

    You have to do this every time you get disconnected or close down the lid.
     
  3. meme291194 thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #3
    It worked!!

    Thank you so much!! It worked immediately :)

    ----------

    Is there anyway to get it to connect automatically because it did before I installed mavericks
     
  4. DrFreeman macrumors member

    Joined:
    Apr 9, 2010
    #4
    Anytime.


    Sadly I have been told that this is an OS issue which means Apple needs to update Mavericks...

    I am surprised they shipped the software with this issue. It is simple to rectify, yet important for everyone!
     
  5. meme291194 thread starter macrumors newbie

    Joined:
    Oct 23, 2013
    #5
    So they are aware of the problem and will attempt to fix it? I hope they do it quickly!
     
  6. DrFreeman macrumors member

    Joined:
    Apr 9, 2010
    #6
  7. jackietong macrumors newbie

    Joined:
    Oct 24, 2013
    #7
    I have a Mac Air 13" bought 2 months ago and encountered the same after the upgrade to Mavericks. I found the discussion for earlier OS X versions below helps. The connections of my wifi with 802.11ac did resume with improved speed.
    https://discussions.apple.com/message/22965279#22965279
     

Share This Page