Max Payne 2 Developer Mode

Discussion in 'Windows, Linux & Others on the Mac' started by Cakefiend, Jul 29, 2008.

  1. Cakefiend macrumors newbie

    Joined:
    Apr 17, 2008
    #1
    Hi, I got Max Payne 2 recently and installed it on my mac via crossover games. It works great but I can't seem to get the cheats working, which you can achieve on windows by doing the following:

    " Start the game with the run command, and type in maxpayne2.exe -developer, or simply right-click on the shortcut [icon] to Max Payne 2. Then, in the Target: line the above bold text.

    Then when the game starts press tilde [~] to open the console. "

    I tried doing the equivalent of the above with "get info" and all that but it doesn't work.

    Anyone know some way around this?
     
  2. NotMike macrumors newbie

    NotMike

    Joined:
    Aug 20, 2008
    #2
    I'm also stuck in this predicament. Any insight/solutions would be much appreciated.
     
  3. s4142614 macrumors newbie

    Joined:
    May 30, 2009
    #3
    Sorry for the wait...

    I figured out how to do it but I'm not at my mac atm... Will post again soon with how to use cheats in max payne 2 crossover :)
     
  4. s4142614 macrumors newbie

    Joined:
    May 30, 2009
    #4
    Ok here it is...

    Remember this is actually the Windows game crossed over to Mac; therefore when developer mode is activated, you use ` or ~ to bring down the console.

    Here's what you do:
    >Locate the Max Payne 2 game in the finder
    >Right click it and select "Show Package Contents"
    >Double click the "Contents" folder
    >Open "Info.plist" (It will open in Property List Manager)
    >Expand the "Root" drop down
    >Go down to where it says "CMOEMCmdLine"
    >The value for this should be "wine --workdir "c:/Program Files/Max Payne 2/" --wait-children --bottle default "c:/Program Files/Max Payne 2/MaxPayne2.exe" --no-sandbox --in-process-plugins"

    All you have to do is double click the value and then change it to this "wine --workdir "c:/Program Files/Max Payne 2/" --wait-children --bottle default "c:/Program Files/Max Payne 2/MaxPayne2.exe" -developer --no-sandbox --in-process-plugins".

    All you have to do is to make it read '...Max Payne 2/" -developer'.

    Good luck :)!
     
  5. maverick237000 macrumors newbie

    Joined:
    Aug 5, 2009
    #5
    please help me...I´m going crazy!!!

    I tried to do exactly as you said, but I can´t even find something that looks like the command line you described....there is nothing like that!

    please send me an email or contact me via skype....I really want this to work!

    thanks in advance for your help an effort!

    skype: mave237000

    email: deyle@goodstuff-pictures.com


    happy thoughts
     
  6. acadie macrumors newbie

    acadie

    Joined:
    Jun 5, 2007
    #6
    any developments concerning the enabling of cheats under CrossOver Games??
     
  7. luv2cheat macrumors newbie

    Joined:
    Nov 28, 2011
    #7
    Try this line entered into the Info.plist

    Sorry for reviving an year old thread,
    but I think this may enable the [~`] key to open the cheat console
    for Max Payne 2 CrossOverGames played on Macs.

    As mentioned before,
    [Right Click] or [Control Click] on Max Payne 2 app for contextual menu:
    Show Package Contents > Contents > Info.plist
    Open Info.plist with TextEdit

    As Maverick237000 mentioned earlier, there is no such line: "CMOEMCmdLine"
    But look & find the following lines instead:

    <key>CXOEMCmdLine</key>
    <string>/Program Files/Max Payne 2/MaxPayne2.exe</string>
    <key>CXOEMCmdLineFlags</key>
    <string></string>

    See the last line listed above: <string></string>

    Well, insert: -developer (minus sign before developer)
    between the <string></string>
    like so, <string>-developer</string>

    Save the Info.plist
    TextEdit > File > Save

    Start up Max Payne 2 as normal
    then see if the [~ '] key brings up a console prompt at the bottom of your screen.
    It's not a dark separate "terminal" window, but a simple: >_ at the very bottom.

    Also, a thin white vertical line will appear on the right side of your monitor.
    Press the [~`] once again to exit the console prompt but
    the white vertical line won't disappear until the [~`] is pressed once more.
    It seems that error logs write on bottom of screen if that white vertical line on the
    right side is still there or "active".

    I've been using the cheat: coder
    God Mode, All Weapons, Health, Infinite Ammo....all rolled into one :D

    Also check to see that your number [1] key is not preset for some kind of movement.
    On mine it was which meant I couldn't utilized grenades & other hand bombs.
    So I reset it to an alternate weapon setting if I remember correctly.
    Nothing like lobbing a continuous rain of infinite grenades to get Max out of an ambush.
    Lame, I know. :eek:
    But fun as hell with the ragdoll effects.

    Hope this helps.
     
  8. kasperkid macrumors newbie

    Joined:
    Mar 30, 2012
    #8
    Huh

    I can't find anything thats called like that
     
  9. huans171, Sep 22, 2013
    Last edited: Sep 22, 2013

    huans171 macrumors newbie

    Joined:
    Sep 22, 2013
    #9
    I found the solution! Guys! No more frustration!

    1. Right click the Max Payne 2 Game Icon.
    2. Click Content and find info.plist.
    3. Open info.plist with TextEdit.
    4. Hit cmd+F to find <key>Program Flags</key>
    <string></string>
    5. Change <key>Program Flags</key>
    <string></string> to <key>Program Flags</key>
    <string>-developer</string>
    6. Save and Close. Enjoy! :)

    *Note: When enter the game press the ~ key once to toggle console and press the ~ key twice to close the console.

    ...one last thing tell those window donkeyholes who won't help our mac folks to go <censored> themselves.
     
  10. Max payne killing me macrumors newbie

    Joined:
    Mar 25, 2017
    #10
    --- Post Merged, Mar 25, 2017 ---
    But still it doesn't work
    nothing comes up on the screen

    anyway Thanks mate
     

Share This Page