max_allowed_packet error in MySQL

Discussion in 'Web Design and Development' started by big_malk, Feb 6, 2009.

  1. big_malk macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #1
    I'm trying to move files from the sever (not uploaded, already there) and the biggest is about 5MB. Small files work fine, but ones over 1MB dont, the query fails with error 'Got a packet bigger than 'max_allowed_packet' bytes'.

    BUT, the annoying thing is, I still get that error even though I've set max_allowed_packet to 16MB, and I've checked it's worked right with SELECT @@max_allowed_packet returning 16777216.

    What can I do?

    Hint: phpMyAdmin gives me this warning "Your PHP MySQL library version 3.23.49 differs from your MySQL server version 4.1.14. This may cause unpredictable behavior."
    I'm using Yahoo! hosting, and I don't have a choice, its what my client has and wants to keep
     
  2. pilotError macrumors 68020

    pilotError

    Joined:
    Apr 12, 2006
    Location:
    Long Island
  3. big_malk thread starter macrumors 6502a

    Joined:
    Aug 7, 2005
    Location:
    Scotland
    #3
    Unfortunately I dont think thats an option, as its a shared server.
     
  4. pbd4499 macrumors newbie

    Joined:
    Jul 20, 2009
    #4
    Yahoo

    hi,

    I've same problem with yahoo:"MySQL library version 3.23.49 differs from your MySQL server version 4.1.14".

    Also I get the message that I have to run the mysql_fix_privelege_tables but I cannot find that script.

    Anyone?

    pbd
     

Share This Page