Maxtor 1TB External Hard drive no longer showing up

Discussion in 'Mac Basics and Help' started by collierjc, Mar 27, 2013.

  1. collierjc macrumors newbie

    Mar 27, 2013
    Maxtor 1TB Basics Desktop USB 2.0 External Hard Drive---

    I have owned the 1TB Hard drive for around a year and a half and use it primarily to store my media files on.

    It has been fine until a couple of days ago, it now will not show up in the finder or the Disk Utility.
    ***This is the same on multiple machines!***

    The strange thing is that when I plug it in to a computer, it starts to make the noise that it is working and the green light appears on the unit.

    I thought perhaps it was a little overworked and unplugged everything a left off to cool down for a while. Plugged everything back in and still the same.

    Both computers are running Lion and have managed to read the hard drive in the past.

    ANY SUGGESTIONS WELCOME!!!! As I have a lot of photos, videos and music that I really do not want to lose!

    Thanks a lot!
  2. davedee65 macrumors regular


    Apr 7, 2010
    As it's not showing up on multiple machines and not appearing in Disk Utility I would suggest that you're looking at possible drive failure. Have you tried using different leads to connect it with?

    When you do plug it in and you say it makes the noise it usually makes, what noise does it make after that? Were there any audible "whir-click" sort of noises? If yes then it's a drive head failure and you should power it off and DO NOT try and turn on or re connect as this could damage the disc and cause date to be lost completely. Are the files it contains the only copies you have?

  3. collierjc thread starter macrumors newbie

    Mar 27, 2013
    The noise it makes is the standard low "murmer" that it (and my other hard drives) make. It is not making any sounds that are out of the ordinary.

    In terms of the cable, I have tried another one with no change in result.

    A lot of the files are the only copies (stupid I know!)

    Definitely no "whir-click" noises but if it is a drive failure is there anything that can be done?
  4. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    Try a Y USB Cable, if the drive needs more power than the USB port on the computer can deliver it won't startup correctly, you could also use an external power supply if the external has a port for it.

  5. benwiggy macrumors 68020

    Jun 15, 2012
    You need to buy some data recovery software, to see if that can get anything off the drive. Data Rescue III is frequently mentioned.

    Failing that, you will need to pay a lot of money to a data recovery company.

    Backup, backup, backup. I can't say it enough times. Files that have no backup are WAITING to be lost.
  6. collierjc thread starter macrumors newbie

    Mar 27, 2013
    It has an external power source!


    Thanks, I will give Data Rescue a try and see if I can drag anything off.

    Any ideas on repairing the hard drive?
  7. justperry macrumors G3


    Aug 10, 2007
    In the core of a black hole.
    Get the drive out of the casing, the casing could also be the problem.

    Recovery software won't work if the Computer doesn't even recognise the HD.

Share This Page