Maxtor External HD error, it doesn't work!

Discussion in 'MacBook Pro' started by mattrussell1124, Apr 23, 2007.

  1. mattrussell1124 macrumors newbie

    Joined:
    Apr 19, 2007
    #1
    i'm severly confused right now.

    i bought a maxtor onetouch III USB2.0. I plugged it into my ibook g4 (os x 10.3.9) and it recognized it but i couldn't open it. so i went online and found drivers from the manufacturer. installed them and nothing happened. when i plugged it in again it failed to be found.

    i took it to my mac guru (i've only been a mac user since december) and he plugged it into his ibook g4 (os x 10.4.?) and it found it. he couldn't write on it however, so he reformatted it, and i believe it worked with his computer. it was still never found on mine when i plugged it in.

    recently, i upgraded to 10.4 and it still won't be found. i plugged it in and left it while i looked for answers and it made me restart, i believe that's called a kernal error. ???. i was thinking maybe i could delete or uninstall the drivers, but i have no idea how.

    terribly frustrating, any help would be greatly appreciated.
     
  2. jbuckner macrumors member

    jbuckner

    Joined:
    Mar 28, 2007
    Location:
    Tulsa
    #2
    Are you sure that your USB port is working? You usually have to reformat a external hard drive to work with OS X. My suggestion is plug it in, run disk utility and reformat the drive using your iBook.
     
  3. mattrussell1124 thread starter macrumors newbie

    Joined:
    Apr 19, 2007
    #3
    mine won't recognize it. and the usb ports work with my flash drive. and we tried reformatting it with the my friend.
     

Share This Page