Maxtor Harddrive not being recognized by Mac

Discussion in 'Mac Basics and Help' started by neonphotography, Jan 2, 2009.

  1. neonphotography macrumors newbie

    Joined:
    Jan 2, 2009
    #1
    I have a 500GB maxtor hard drive for a couple months, its formated to mac every-things fine, then today my mac crashed and shut it down while i was backing things up, now the mac cant see the hard drive, I've tried several times and checked in disk utility but it cant see anything, any advice on what I should do as I had things on that hard drive that I needed?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    From Apple:


    1. From the Apple menu, choose Shut Down (or if the computer is not responding, hold the power button until it turns off).

    2. Unplug all cables from the computer, including the power cord and any display cables.

    3. Wait at least 15 seconds. (Just to be sure I waited five/5 minutes.)

    4. Plug the power cord back in, making sure the power button is not being pressed at the time. Then reconnect your keyboard and mouse to the computer.

    5. Press the power button on the back to start up your computer.



    It helped recognizing my FW800 drive again.
     
  3. sawmaster macrumors regular

    #3
    Same here...

    Yeah i got the same issue! I tried the above, and it didn't work for me, I gotta 320 GB portable maxtor hdd. and itunes just tried to dump my entire library. so i freaked out and ripped the cord. now its not reconizing. it just blinks for minutes. i'll let it sit maybe. anybody got ideas!?!?!?! i got SO MUCH IMPORTANT INFO!!!! if i lost my stuff, i won't worry. i'll just goto the fbi and they'll recovor it! :D
     
  4. sawmaster macrumors regular

    #4
    never mind! mine works now. just plug it in for awhile. i saw it reconized while i was posting LOL
     

Share This Page