Maxtor One Touch III Firewire (Not Recognized)

Discussion in 'Mac Basics and Help' started by i.shaun, Oct 11, 2008.

  1. i.shaun macrumors 6502a

    i.shaun

    Joined:
    May 1, 2008
    Location:
    Canada
    #1
    Over time, since the beginning of my mac experience, I have run into many problems, and found many solutions, whether it was on my own, or with help from you fellow macrumors members.

    I recently re-installed OS X Tiger 10.4.11 on my iMac5,1. I also upgraded my network from an old wired D-Link router to an Apple Airport Extreme, and it works wonderfully. The clean install of Tiger fixed a lot of issues developed over time from my doing, and now even Media Link works. I was never able to figure it out, support on their site never contacted me, and no one here seemed to know what to do, as their all seemed to work.


    Anyway, I have fixed all but One problem. One that was been put aside for quite a long time, and now (if possible) I intend to fix it.


    I have a Maxtor One Touch III 300GB Portable HDD, which contains:
    -1 AC adaptor port
    -1 USB port
    -2 Firewire 400 ports
    -power switch on back
    -One Touch Button on front (for automated backups, which I will NEVER do again..not after last time..)


    It works fine on USB, the reason I wish to get firewire up is so that I can keep it plugged in to the PS3, and also the iMac at once.




    I did the following:
    -Powered on the HDD
    -Plugged in the fire wire to the imac, and then to the HDD
    -waited.

    then, after seeing nothing mount, i:
    -checked disk utility, and found nothing
    -checked system profiler, and found "Unknown Device" under firewire
    -Rebooted the system

    Nothing has changed.


    I'm sure the possibility exists that the firewire is damaged, I've tried multiple ports, and nothing showed. The firewire ports should be new, the only think I ever tried plugging in was that HDD, as it's the only firewire device I own.


    Any suggestions on what could be causing this? other than a burnt firewire port. If the port is indeed burnt, why would it display "unknown device"? Shouldn't it just be completely unresponsive?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    There's an Apple suggested procedure that worked for me and my Firewire drives when they were not mounting.

    Turn of the iMac, unplug everything, even the power cable.
    Wait at least 15 seconds (I usually waited 5 minutes just to be on the safe side).
    Plug in the power and the mouse and keyboard.
    Start the iMac.
    Wait till it is fully booted/logged in.

    Try now to just connect the Firewire drive via firewire and see if anything happens.

    If not, and if you have another Firewire drive handy, try if that drive is recognized. If so, return the faulty drive to where you bought and claim for a repair or replacement.
     
  3. i.shaun thread starter macrumors 6502a

    i.shaun

    Joined:
    May 1, 2008
    Location:
    Canada
    #3

    Hmm, is this some sort of reset procedure? I remember doing that on a PC to erase the BIOS password.

    As for returning the drive, that is no longer an option. As I have said, it's been put aside for quite some time, the warranty, and even the receipt are non-existent at this time. The drive works fine though, via USB.

    I will try the reset procedure, I'll un plug it, and watch a movie or something -- that should be plently long enough.
     
  4. i.shaun thread starter macrumors 6502a

    i.shaun

    Joined:
    May 1, 2008
    Location:
    Canada
    #4
    Thank you, Good sir.

    The procedure worked flawlessly. I unplugged it for about 30 minutes, logged back in, powered the HDD up, and connected my firewire port. The 2 partitions mounted immediately after.
     

Share This Page