Resolved MB 4,1 (early-mid 2008) & western digital WD7500BPVT - disk not found

Discussion in 'MacBook' started by luettich, Dec 12, 2012.

  1. luettich, Dec 12, 2012
    Last edited: Dec 16, 2012

    luettich macrumors newbie

    Joined:
    Dec 12, 2012
    #1
    Hi everybody,

    I got myself a western digital WD7500BPVT hard drive (750 GB) for my White MacBook Model 4,1 (mid 2008) with SATA controller Intel ICH8-M AHCI running at 1,5GB/s and Snow Leopard 10.6.8. The problem is that the drive won't be found at bootup. The system just won't do anything. When I connect the drive via USB adapter there isn't any problem at all. At first I tried cloning my old Fujitsu Hard Drive (160 GB) with Carbon Copy Cloner, which worked fine. But after installing the new drive in the computer, the mentioned issue occured. same after formatting the new drive with disk utility again.

    Is this a known issue?? I've read a few threads and it seemed to me that it couldn't be a controller issue because e.g. someone said it worked with a Macbook 3,1 having the same controller. So could there be any other reason which is especially relevant to the model I have??

    Any help is greatly appreciated! Thank you
     
  2. luettich thread starter macrumors newbie

    Joined:
    Dec 12, 2012
    #2
    Problem solved

    I have found the reason - it has to do with formatting the new drive. I did this while it was connected via USB, then cloned my old drive. However, when I lateron booted up from the installation DVD and started disk utility, it recognised the new disk (which I had built into the computer) and showed that a huge part of the partition I created wasn't accessible. I don't know why that was the case, but I then just formatted the new drive again and was able to do a clean install of Mac OS from DVD. Now it works fine, the drive is superfast and quiet - recommendable!
     

Share This Page