MB Internal Speaker doesn't work after Yosemite

Discussion in 'OS X Yosemite (10.10)' started by jasonpoon, Jul 27, 2014.

  1. jasonpoon macrumors newbie

    Joined:
    Mar 5, 2007
    #1
    Everything seems fine after installing Yosemite public beta, besides the audio part.

    I still can get the audio with headphone plugged in, but without headphone, the system keeps switching the output device to the AirPort Express Airplay instead of internal speaker. (I use the original AirPort Express as router but no audio device are connected to it)

    I try to click the internal speaker in System Preferences, or do it by option-click the audio icon on menu bar. But both doesn't work, I can click the "Internal Speaker" option but still no audio from speaker, when I checked the setting the AirPly option is checked again.

    The only time I can make the internal speaker works is when I disconnected from the AirPort Express. Without AirPlay detected, the internal speaker works again.

    Anyone has the issue too after Yosemite? I hope it isn't because of me using an older generation AirPort Express, it works fine I don't wanna get a new one yet.
     
  2. peasnrice, Jul 27, 2014
    Last edited: Jul 30, 2014

    peasnrice macrumors newbie

    Joined:
    Jul 27, 2014
    #2
    Same Issue

    Same problem here, Internal Speakers stop working when airplay devices are found on my network.

    When I disconnect from the network, the internal speakers start working again.
    I have an Asus RT-N16 router so I'm certain it has nothing to do with your Airport Express.

    [EDIT] I did not realize that the old airport express was capable of airplay, thought it was apple's router thing. My mistake.

    App specific settings allow me to get sound from the internal speakers, Skype and Google hangouts for example. Just change the settings to internal speakers and you should get sound for those. It's the OS Audio settings that don't seem to work.
     
  3. laruensdeblocq macrumors newbie

    Joined:
    Jul 30, 2014
    #3
    Solution for this?

    I have the same problem.. any solution? Without changing network or turning off airplay?
     
  4. colinsco macrumors newbie

    Joined:
    Aug 28, 2014
    #4
    Same problem here. December 2013 MBP. Stuck on airplay as soon as I turn the WiFi on.
     

Share This Page