MB Pro 13" 2010 - just beeping

Discussion in 'MacBook Pro' started by millereffect, Jan 7, 2012.

  1. millereffect macrumors newbie

    Joined:
    Aug 1, 2011
    #1
    Hello,
    I have a defect logicboard of a Macbook Pro 13" model 2010 2.4Ghz which was liquid spilled a while ago. I would like to ask you for your help.

    The macbook shows the following symptoms. I can start it normally but it is just beeping and the led is flashing. That's it, no booting, only black screen, no initial dvd drive sound.

    I have already tried to replace the ddr memory and tested each bank but no difference. It even makes no difference of the beeping if memory is installed or not.

    I have taken off the board from the macbook body and power it up with the magsafe adapter. Then it is always running by itself without having the power button pushed. I checked that there is no 32k rtc and also no clock to the ddr memory slots. The 25mhz clock for the mcp is there. I also checked every voltage for correct value but everything is fine voltage related.

    I am assuming the the mcp is dead or is heavier damaged than I thought but as this is not that often the case I ask you out there if anybody has an idea where I could finally look for before I have to dump it.

    Many thanks!
     
  2. Krazy Bill macrumors 68030

    Krazy Bill

    Joined:
    Dec 21, 2011
    #2
  3. zyr123 macrumors 6502

    Joined:
    May 31, 2009
    #3
    sorry

    If it beeps 9 times thats your logic board, if they charge you half the price of the computer just get a new one. thats what happend to my old mac.
     

Share This Page