MB Pro 17 i7 2.3 GHz mouse will not wake from sleep

Discussion in 'MacBook Pro' started by niceguyeddie, Aug 15, 2011.

  1. niceguyeddie macrumors member

    Joined:
    Jul 3, 2008
    #1
    I have a new Macbook Pro 17 2.3GHz i7 which will not wake from sleep via mouse or the trackpad. I have to hit spacebar to get it to wake up. It is really annoying.

    I have tried disabling the graphics switching as well as doing a touch on the extensions, but still have the problem.

    Has anyone else seen this problem? Anyone got a fix?

    Cheers
     
  2. mape2k macrumors regular

    Joined:
    Apr 18, 2011
    Location:
    Germany
    #2
    Mine does the same, but I always thought it to be normal?
     
  3. niceguyeddie thread starter macrumors member

    Joined:
    Jul 3, 2008
    #3
    I hope it is not normal. I have just switched from a 2008 Macbook Pro 17, the model before unibody, and I could always wake that with mouse or trackpad.
     
  4. Tastydirt macrumors member

    Joined:
    Sep 25, 2009
    #4
    It changed with Lion, now instead of just moving the mouse you've got to click it or press a key. IMO this is an improvement as its too easy to accidentally wake it up just by a minor mouse movement, and it doesn't take long to get used to clicking the mouse.
     
  5. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #5
    You'd have to have the computer allowed to wake up from USB or bluetooth for it to work, have you checked your system preferences?
     
  6. Mobius 1 macrumors 6502

    Joined:
    Feb 11, 2011
    Location:
    USEA
    #6
    enter

    sudo pmset hibernatemode 0 in terminal

    and var/vm/sleepimage
     
  7. Fry-man22 macrumors 6502

    Fry-man22

    Joined:
    Nov 25, 2007
    #7
    If you guys are running Lion it doesn't matter what version MBP you have it wants you to click the trackpad or hit a key to wake up. On <10.7 you could just swipe the pad or move the mouse and it would wake up - now it will only wake if you click a button/key.

    Don't listen to the fellow with the terminal commands unless you want to disable hibernation - that hint has nothing at all to do with the "wake up" behavior, only the sleep method used.
     
  8. niceguyeddie thread starter macrumors member

    Joined:
    Jul 3, 2008
    #8
    Thanks for clearing that up.

    Maybe you could help with another problem I have with the new MBP? With my previous MBP 17 I could wake it from sleep and control it remotely from my MB Air while both machines are running off the same wireless network. However, with the new one I can't wake it from sleep. Has this behaviour been disabled as well?

    Cheers
     
  9. Minhthien macrumors 6502

    Joined:
    Jun 20, 2011
  10. Fry-man22 macrumors 6502

    Fry-man22

    Joined:
    Nov 25, 2007
    #10
    Check in the energy settings for a "wake on network access" or similar option. Pretty sure it's there but I'm not at my Mac right now.
     

Share This Page