MB Pro Hesitates or Delays on Simplest Tasks

Discussion in 'MacBook Pro' started by ddyerkc, Sep 14, 2011.

  1. ddyerkc macrumors newbie

    Joined:
    Sep 14, 2011
    #1
    Does anyone have this issue that I am experiencing where it seems like everything I do on my mb pro gives a slight hesitation before it completes the task? It could be something as simple as scrolling down, it will wait a second and then start scrolling. Or when I am watching a video, the video will freeze just for a half second, every 5-10 seconds.

    I have installed Lion and was experiencing this annoying hiccup, so I did a clean install and installed again and I still experience it now and again.

    Could this have something to do with the Spotlight?
     
  2. MPB11 macrumors regular

    Joined:
    Feb 2, 2011
  3. darkus macrumors regular

    Joined:
    Nov 5, 2007
    #3
    Yep, I get the same issue, I have a bad feeling these are defective versions since such a powerful CPU should obviously not have these problems on simple tasks...

    The hiccups happen in both OSX and my windows bootcamp partition, so I assume its a systemic issue related to the CPU/Motherboard/RAM.
     
  4. maril1111 macrumors 68000

    maril1111

    Joined:
    Mar 14, 2010
    Location:
    Denmark
    #4
    Same and mine randomly freezes as well, i have brought it to service ones but they couldn't diagnose an error so they just switched hd cables. Now its in repair for the second time with the same problem... altogether i have been laptopless for 2 weeks...
     
  5. smali macrumors regular

    Joined:
    Jul 19, 2010
    #5
    I had a similar problem on mine (2.2 i7 hi res) but I solved it.

    I noticed that my machine would also seem like its frozen every so often just for a second or two. I noticed that when these freezes happened I could hear the hard disk spinning up and also my two external start spinning (even if I am not accessing them). I figured out there must be some problem with Lion's energy saver setting.

    I turned off the option "Put hard Disks to sleep whenever possible" and now I never have that problem.

    Also I noticed that my performance in some games would drop badly even though it was running amazingly before. Funny thing is this was also solved with a setting in the energy saver. I turned off automatic graphics switching and the unstable performance is gone.

    Looks like Lion's energy saver settings are way too aggressive, even plugged into the mains. It shouldn't be switching stuff off mid high process tasks like the discrete card during video games.
     
  6. MPB11 macrumors regular

    Joined:
    Feb 2, 2011
    #6
    did u guys experience this issue on SL or only on Lion? I'm still on SL and experience it on it.
     
  7. maril1111 macrumors 68000

    maril1111

    Joined:
    Mar 14, 2010
    Location:
    Denmark
    #7
    Lion more than Snow Leopard, but i had internet dropouts in sl instead..
     
  8. MPB11 macrumors regular

    Joined:
    Feb 2, 2011
    #8
    I turned off the Put hard Disks to sleep whenever possible function, we'll see what happends, hope it's not related to the sandy bridge problem revealed back in january.
     
  9. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #9
    Im running 10.7.1 and sometimes, have that problem.
    Not always but once in a while.
    I thought it was because there wasnt enough RAM so I am thinking to upgrade to 8GB.
     
  10. MPB11 macrumors regular

    Joined:
    Feb 2, 2011
    #10
    It's probably not RAM related IMO because it does it while havinh only one web page open.
     
  11. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #11
    Are you using safari?
    Because just opening safari uses like 1.7GB lol

    But I cant be sure because I have like 5 apps that opens on start up so.
    I also use my dashboard which is a RAM eater.
    As myself, 4GB isnt enough.
    When you open couple applications or maybe 1 RAM eating app and another, you notice lag. It gets very irritating :/
     
  12. MPB11 macrumors regular

    Joined:
    Feb 2, 2011
    #12
    I use firefox, but I'll try turning off dashboard, how do you do it?
     
  13. yusukeaoki macrumors 68030

    yusukeaoki

    Joined:
    Mar 22, 2011
    Location:
    Tokyo, Japan
    #13
    Just dont open dashboard after bootup.
    It can lessen the usage of RAM if you turn off all you widgets too.
     
  14. maril1111 macrumors 68000

    maril1111

    Joined:
    Mar 14, 2010
    Location:
    Denmark
    #14
    You can actually disable the dashboard:

    go to terminal and copy&paste this command:


    defaults write com.apple.dashboard mcx-disabled -boolean YES

    and hit enter (return)

    than you type killall Dock

    and hit enter (return) again.



    To enable the dock again you copy&paste:

    defaults write com.apple.dashboard mcx-disabled -boolean NO

    hit enter again and than type killall Dock and hit return(enter again)

    Hope this helps.. btw safari doesn't use 1.7gb by just opening it you do have to have some tasks running I am right now using a MBP with 1gb ram and safari....
     
  15. mark28 macrumors 68000

    Joined:
    Jan 29, 2010
    #15
    If the problem is only with the 2011 MBP's, then an EFI update will fix it. Not sure when it will come.
     

Share This Page