MB5,1 Ethernet Not working with LION - False Alarm. disregard

Discussion in 'Mac OS X Lion (10.7)' started by hekokimushi, Jul 28, 2011.

  1. hekokimushi, Jul 28, 2011
    Last edited: Jul 28, 2011

    hekokimushi macrumors regular


    Oct 27, 2008
    Sorry this may seem a double post. but i just wish to fix this ASAP

    i did start a thread in the Macbook forum. and here it is again.

    i normally just use my Wifi. everything seems transparent.
    cleaned installed Lion on me SSD.

    I thought my MB5,1 was a very successful running Lion 10.7.1, working flawlessly, until this morning.
    My Hackintosh's Mainboard's CR2032 battery is dead/flat, which caused boot problems. including LAN. i troubleshoot by putting the LAN cable to my macbook, instead of picking up an assigned IP from the router of 192.... it stays at 169... as an IP address wouldn't update thought it must be the cable or the router port, i tried another cable that i took off from another online computer to the same router that was working, hooked up with the MB, same 169.... same IP, rebooted the router, same.

    put the same cable back to another computer, picks up the normal IP 192... tried one last time with the MB. nope 169...

    i restarted my macbook. same same.

    Anyone's MB5,1 have their Ethernet working? with ability to pick up an IP from DHCP or router?

    any chance to have your kext please?



    Reason for edit, for whatever reason, my router had my macbook's LAN port's MAC address. never thought they would cause any conflicts. but it did. changed the mirror address to something else... all working fine. back to flawless thus far. recommend a CLEAN LION install for any units.

Share This Page