MBA 11" won't go into standby mode

Discussion in 'MacBook Air' started by sneak3, Jan 12, 2012.

  1. sneak3 macrumors 6502

    Joined:
    Oct 14, 2011
    #1
    Hello!

    I've just discovered that macbook airs have this amazing feature that saves lots of battery when in sleep mode.

    However I've noticed that mine doesn't perform as it should.

    I charged the battery to 100% and closed the lid. Next morning the battery had dropped to 88%.

    The standby feature tells that, when in sleep mode, after one hour, macbook air will go into standby mode and then its battery will last 30 days.

    I've run the command "pmset -g" and here's the following:

    Active Profiles:
    Battery Power -1*
    AC Power -1
    Currently in use:
    standbydelay 0
    standby 0
    halfdim 1
    panicrestart 157680000
    hibernatefile /var/vm/sleepimage
    disksleep 5
    sleep 10
    hibernatemode 3
    ttyskeepawake 1
    displaysleep 5
    acwake 0
    lidwake 1

    I see that the "standby" is 0. Shouldn't it be another number?

    Please, any tip is great!

    Thanks!
     
  2. doktordoris macrumors 6502a

    doktordoris

    Joined:
    Mar 14, 2009
    #2
    what you re looking for is called hibernate mode I think

    Apple hibernation has three modes. By default, on laptops it suspends the system and make a copy of RAM to disk for a completely safe hibernate.
    You can change the Mac’s hibernate behavior using pmset; here’s the reference for it:
    http://developer.apple.com/documentation/Darwin/Reference/ManPages/man1/pmset.1.html
    “sudo pmset -a hibernatemode 0″ = suspend to RAM only (default on desktops)
    “sudo pmset -a hibernatemode 1″ = suspend to disk only
    “sudo pmset -a hibernatemode 3″ = suspend to disk + RAM (default on laptops)
    To see your current hibernatemode: “pmset -g | grep hibernate mode”.


    your machine is hibernate mode 3 which is as it should be.
     
  3. iaymnu macrumors 6502

    Joined:
    Mar 23, 2007
    #3
    its in hibernate mode 3 which suspend to disk + RAM .
    Download smartsleep.
     
  4. eric/ Guest

    eric/

    Joined:
    Sep 19, 2011
    Location:
    Ohio, United States
    #4
    I think it should be a "1". Would definitely call Apple or speak with a genius though unless you want to try fixing it yourself. I'd back your computer up too, you never know.
     
  5. sneak3 thread starter macrumors 6502

    Joined:
    Oct 14, 2011
    #5
    Hmmm so how come the battery still decreases like a regular macbook pro in sleep mode?

    I don't see how it would last 30 days with this battery drop rate.

    What am I doing wrong or what is it missing?
     
  6. iaymnu macrumors 6502

    Joined:
    Mar 23, 2007
    #6
    have you changed the hibernation mode?

     
  7. sneak3 thread starter macrumors 6502

    Joined:
    Oct 14, 2011
    #7
    Yes, using those hibernate commands all that's changed is the hibernation, but the standby is still 0.

    I really think it shouldn't be 0, if you think logically, 0 mean not enabled.

    But the mba is brand new, I've never messed up with it. And I really think this standby thing should be the default option.
     
  8. doktordoris macrumors 6502a

    doktordoris

    Joined:
    Mar 14, 2009
    #8
    i just spent a few minutes searching online for combinations of pmset-g, power, sleep, and standby/delay and I can find nothing that even mentions standby. I can find mention of sleep delay, which is time until sleep in minutes, I believe.
     
  9. iaymnu, Jan 12, 2012
    Last edited: Jan 12, 2012

    iaymnu macrumors 6502

    Joined:
    Mar 23, 2007
    #9
    from man page. http://www.manpagez.com/man/1/pmset/


    hibernatemode takes a bitfield argument defining SafeSleep behavior. Passing 0 disables SafeSleep altogether, forcing the computer into a regular sleep.

    standby causes kernel power management to automatically hibernate a machine after it has slept for a specified time period. This saves power while asleep. This setting defaults to ON for supported hardware. The setting standby will be visible in pmset -g if the feature is supported on this machine.

    standbydelay specifies the delay, in seconds, before writing the hibernation image to disk and powering off memory for Standby.

    If you need to set in sleep mode and turn on the standby mode

    Code:
    sudo pmset -a standby 1
    
    You can change the time you want your laptop to wait before going into hibernate mode
    Code:
    sudo pmset -a standbydelay number of seconds
     
  10. sneak3 thread starter macrumors 6502

    Joined:
    Oct 14, 2011
    #10

    Ah that explains it all.

    However, as the very article states, the default setting is ON. How come my mba isnt set to default?

    Is there another way of enabling standby other than the terminal codes?

    I really want to figure that out. What would be the regular user, little kid-old people way for turning that on?
     
  11. iaymnu, Jan 12, 2012
    Last edited: Jan 12, 2012

    iaymnu macrumors 6502

    Joined:
    Mar 23, 2007
    #11
    I don't know another way of enabling other than terminal.
    Not sure why it isn't set to default.

    Mine is set to 1 and my delay is 4200.
    my profle
    Code:
    Active Profiles:
    Battery Power		-1*
    AC Power		-1
    Currently in use:
     standbydelay	4200
     standby	1
     halfdim	1
     panicrestart	157680000
     hibernatefile	/var/vm/sleepimage
     disksleep	0
     sleep		60
     hibernatemode	0
     ttyskeepawake	1
     displaysleep	5
     acwake		0
     lidwake	1
    
     
  12. KPOM macrumors G5

    Joined:
    Oct 23, 2010
    #12
    That happened to me once (it wouldn't go into deep sleep). Try restarting it and see if that helps. A reboot did the trick. If that doesn't work, try resetting the SMC.

    http://support.apple.com/kb/ht3964

    I think what is happening is that something is causing your Mac to think that something is plugged into the USB port and is active. That can prevent your Mac from going into deep sleep mode. Do you have anything plugged in? If so, unplug it and try again.

    Ideally, the Mac should drop into deep sleep mode after 70 minutes. Over a typical night, it loses about 3% of the battery.
     
  13. sneak3 thread starter macrumors 6502

    Joined:
    Oct 14, 2011
    #13
    Nothing is connected, no.

    The only thing that could be considered a little bit strange is a program called PARAGON NTFS, which enables mac to read ntfs partitions.

    Could that be the cause?
     
  14. KPOM macrumors G5

    Joined:
    Oct 23, 2010
    #14
    I don't know. Perhaps it is causing the Mac to think something is installed. Maybe try deactivating it and see if it goes into deep sleep.
     
  15. sneak3 thread starter macrumors 6502

    Joined:
    Oct 14, 2011
    #15
    So there's no way the standby could be disabled by a regular change in system prefs, for example?

    It has to be something I installed?
     
  16. sneak3 thread starter macrumors 6502

    Joined:
    Oct 14, 2011
    #16
    Damn even with the terminal command switching the standby from 0 to 1, no change at all.

    I cant believe im gonna have to reinstal lion..

    Could any of you guys who own a macbook air with the standby feature check out the pmset -g to find out the parameters?
     
  17. doktordoris macrumors 6502a

    doktordoris

    Joined:
    Mar 14, 2009
    #17

    unknown-b8-8d-12-07-86-4c:~ doktordoris$ pmset -g
    Active Profiles:
    Battery Power -1
    AC Power -1*
    Currently in use:
    standbydelay 4200
    standby 1
    womp 1
    halfdim 1
    panicrestart 157680000
    hibernatefile /var/vm/sleepimage
    networkoversleep 0
    disksleep 10
    sleep 20
    hibernatemode 3
    ttyskeepawake 1
    displaysleep 20
    acwake 0
    lidwake 1
     
  18. ml11 macrumors newbie

    Joined:
    Jan 17, 2012
    #18
     
  19. sneak3 thread starter macrumors 6502

    Joined:
    Oct 14, 2011
    #19
     
  20. Surely Guest

    Surely

    Joined:
    Oct 27, 2007
    Location:
    Los Angeles, CA
    #20
    I've been having issues with my MBA going to sleep when I close the lid (not always, but it happened maybe 6 times this past week). Normally, the unit goes quiet, but those 5-6 times, the fans kept on running, and the only way I was able to get it to go to sleep was to restart it first. Any ideas?


    Decided to have a look see, and here is mine:


    Battery Power -1
    AC Power -1*
    Currently in use:
    standbydelay 4200
    standby 1
    womp 1
    halfdim 1
    panicrestart 157680000
    hibernatefile /var/vm/sleepimage
    networkoversleep 0
    disksleep 10
    sleep 0 (imposed by 47)
    hibernatemode 3
    ttyskeepawake 1
    displaysleep 8
    acwake 0
    lidwake 1

    Can anyone explain the bolded "sleep" line to me?
     

Share This Page