MBA 13 inch so excited but...

keepingup

macrumors member
Original poster
Jan 14, 2011
56
3
It's only day 1 but already feel old and stupid. How do I get all my iMessages on MBA? I am signed into icloud but only receive gmail texts on MBA. I tried add account but it doesn't let me put in the cell phone #. I asked the guys at Verizon. They didn't have a clue.
 

Dr Charter

macrumors 6502
Feb 26, 2011
275
8
Oklahoma
It's only day 1 but already feel old and stupid. How do I get all my iMessages on MBA? I am signed into icloud but only receive gmail texts on MBA. I tried add account but it doesn't let me put in the cell phone #. I asked the guys at Verizon. They didn't have a clue.
Have you tried signing into iMessages on the phone? That is how I got mine to show up on the Air. You are correct that there is no "add phone number option" on the computer.
 

keepingup

macrumors member
Original poster
Jan 14, 2011
56
3
Just checked. I am signed in on iPhone. Could you be more specific about what you mean?
 

DmbShn41

macrumors 6502
Jun 22, 2009
295
2
Go to Settings -> Message, and make sure that iMessage is on. Also, go into System Preferences on your MBA, select iCloud and make sure iMessages is turned on there. Lastly, open up iMessage, go tot Preferences ->Accounts and make sure your info is there.
 

Dr Charter

macrumors 6502
Feb 26, 2011
275
8
Oklahoma
Follow Dmb's instructions. He said it better than I did. You just have to make sure iMessages is logged in and turned on on all of your devices.
 

keepingup

macrumors member
Original poster
Jan 14, 2011
56
3
Thanks to both of you but alas, no luck. I use an iPad, iPhone and the new MBA. All are turned on in Messages or iMessages. Still can't put phone number into add account on MBA message. I made an appt. at Apple store Genius Bar on Tuesday in case "we" don't figure it out before then.
 

Boyd01

Moderator
Staff member
Feb 21, 2012
4,489
2,016
New Jersey Pine Barrens
In the Messages App on your Mac under Preferences > Accounts, what do you see? Are there no accounts listed in the left pane of the window? What happens if you click the plus button [+] at the bottom of the pane? That should allow you to add your e-mail and phone number.
 

keepingup

macrumors member
Original poster
Jan 14, 2011
56
3
All three devises are now signed into my gmail address and my cell phone number. The iPad and iPhone settings have "start new conversations from" and the phone # is checked, not the email. Is that correct? Or should I start new conversations from gmail and uncheck phone#? Afraid to mess it up (even more)
 

dirtnnasty

macrumors member
Dec 16, 2013
87
0
u cannot enter your phone number. deactivate iMessage on your phone and activate it again. Normally now you get a message on your mac that iMessage is available (or something like that) and your mac configurate it by itself. Then enter iMessage and you find a iMessage account with a list of emails and numbers u use for iMessage and which one you want to use on your mac.
 

keepingup

macrumors member
Original poster
Jan 14, 2011
56
3
success, I think. No old iMessages are on MBA but when I send new ones now they go from all three devices as regular iMessages. My list of contacts is not there; I think Contacts got all messed up in iCloud download. Looks like I have to redo my entire contacts and also manually put in phone numbers to start new iMessage conversations. Is that correct? sigh, what I would give for an Apple savvy 25 year old. My two daughters rely on my. Pity them!
 

scaredpoet

macrumors 604
Apr 6, 2007
6,627
342
Are your contacts all synced to iCloud? They should all sync to all your devices and show up there.
 

keepingup

macrumors member
Original poster
Jan 14, 2011
56
3
Thank you, yes all devices are on icloud. I think it's confusion because I have both an apple address book and gmail contacts. Can't figure out which is what. I don't mean to sound stupid but this is really so confusing.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.