MBA 2010 Can't Erase/Partition corrupt internal SSD

Discussion in 'MacBook Air' started by DanEp, Jan 15, 2012.

  1. DanEp macrumors member

    Joined:
    Jan 7, 2012
    #1
    I was unable to boot. Tried recovery partition tools starting with First Aid but to no avail.

    So I decided to erase and reinstall os x lion. I am unable to do this so far.

    1. I tried erasing the volume Macintosh HD. Volume Erase failed with the error: File system formatter failed.

    2. I tried to erase the 121.33 GB Apple SSD. Disk Erase failed with the error: Couldn't unmount disk.

    The disk is mounted since the recovery partition is what I'm using. So...

    I rebooted with a good OS X Lion installation from an external USB drive (no problems), retried and got this result: Disk Erase failed with the error: Unable to write to the last block of the device.

    3. If I try to partition the 121.33 GB Apple SSD I get: Parrtition failed with the error: Unable to write to the last block of the device.

    I thought I would use superduper or ccc to clone back the (repaired) image of the SSD but when I launch either program they do not see the 121.33 GB Apple SSD so this route leads to a dead end also.

    4. I tried using the Disk Utility Restore function using a variety of Sources and get the following error: An error (22) occurred while copying. (Invalid argument)

    I am out of ideas. I can't take the SSD out of the macbook air and put it into an external enclosure and try formatting. I can't use the internet installation method since it is a 2010, and not 2011 Macbook Air.

    I did a lot of googling and tried a lot of the suggestions but so far I'm stopped dead in my tracks. I am able to boot the macbook air using an external drive and recovery partition is usable, either on external drive or internal SSD.

    Any ideas would be greatly appreciated. I'm out of warranty and out of ideas.
     
  2. DanEp thread starter macrumors member

    Joined:
    Jan 7, 2012
    #2
    SSD Failure

    All Hardware Diagnostics tests passed. I was unable to diagnose further, and so I made an appointment to meet the folks at the Apple Genius Bar.

    They confirmed my suspicion that I have a defective SSD or SSD controller. MBA lasted 88 days beyond the 1 year warranty.

    I've never had a drive fail on me and given this is my first SSD, I'm frankly surprised and disappointed. Further details on my futile attempt to mount, partition and zero out the drive are available here:

    https://discussions.apple.com/message/17315913#17315913
     

Share This Page