MBA and Airport Express Connection Problems

Discussion in 'MacBook Air' started by mrossi, Aug 3, 2009.

  1. mrossi macrumors newbie

    Jan 21, 2009
    Hi, I'm having a problem connecting my mba to an airport express wireless network. Hoping someone might be able to help...

    (note: I'm posting this using a friend's PC, so apologies if the question has been answered before, but the time I have to browse through the forums is rather limited...)

    Here's the situation:

    I'm on holiday in a very remote area and don't have an internet connection where I'm staying, but there is a cafe nearby with some form of broadband using an airport express router. The owner is quite happy for anyone to use the connection. I'm unsure about the exact router settings as I don't have access, but as far as I can tell it's running a totally unencrypted (!) G network using DHCP. For some reason, my mba is having a big problem trying to connect. It does seem to connect fine at first, but when checking the airport settings in more detail, I see an error message telling me that "airport is connected, but has a self-assigned IP address", in the range 169.x.x.x.

    The strange thing is, I can't even connect when using my windows 7 bootcamp partition. The ssid is listed, but when trying to connect the error message simply reads "Windows cannot connect to this network". I found this very strange, so I tried to connect with my iphone, and it works absolutely fine! The IP address assigned to the iphone is in the range 10.0.0.x (which I'm guessing is the default for airport express routers?). Clearly, the mba is not being assigned an IP for some reason.

    To top it all off, there was a person sitting next to me with a Dell which was working absolutely fine. grrr.

    So, I thought this might be a hardware problem, but there aren't any other wireless networks around to test. So, I borrowed a friend's windows laptop and created an ad-hoc connection to my mba. This worked fine, so I'm thinking my wireless card isn't broken.

    I'm running the latest firmware on my mba (assuming no update has come out in the last 2 days), but I'm unsure whether or not the router itself is up to date. Also, I've checked all my aiport settings 100 times over to make sure they are all on the correct values (i.e. DHCP enabled, no static IP's etc). As far as I can tell, everything on my end checks out. Even in windows, everything is on default/automatic. My mba was working perfectly before I came away.

    My only thought is that there is some strange incompatibility between my mba wifi card and the router (which seems very unlikely), or something to do with the particular settings currently in use by the router. I guess if the router has some out of date firmware this would also be a possibility, but I'd like to eliminate any other options first before I go complaining to the owner that my particular laptop doesn't work and he should update etc, when every other computer seems to work fine...

    Has anyone come across this kind of problem before??
  2. kntgsp macrumors 6502a

    Jul 27, 2004
    Is it a Rev. A, B, or C?

    If the Rev. A it is almost assuredly a different problem. But there is a current Wi-Fi issue with all current Macbooks, not just the Air that results in connections being dropped on certain routers. I haven't had any problems with a Belkin N+ router, so it could possibly be your router model.
  3. mrossi thread starter macrumors newbie

    Jan 21, 2009
    Can't believe I forgot to mention this: It's a rev.B mba.

    I did hear that there are some wifi issues, though this is the first time I've encountered any, and certainly didn't think it would be a problem when using Apple only products.

    Also, its not so much the connection being dropped, but rather that no "proper" connection is being made. My mba isn't being assigned an IP, so I would argue i'm not even conneted in the first place.
  4. stoconnell macrumors 6502

    Mar 22, 2009
    Rockville (Despite REM's plea.)
    It's interesting that happens both in windows and in OSX. If only the latter, I would have suggested a permissions problem. Do you see anything in telling in /var/log/system.log when in OSX? Do you have any previous settings associated with the SSID that is chosen? You might consider deleting any settings.

    It could also be that Airport Express could have a firmware issue or needs to be reset (couldn't hurt) -- maybe the owner would be willing to try resetting the unit and/or checking to see if there are any updates to the firmware and applying them.

    Good luck.

Share This Page