MBA cannot recognize external HD

Discussion in 'Mac Accessories' started by garvatron, Oct 19, 2013.

  1. garvatron, Oct 19, 2013
    Last edited: Oct 19, 2013

    garvatron macrumors newbie

    Joined:
    Aug 23, 2008
    #1
    I have a rather old (4 years old) 1 TB Lacie external HD. One day I couldn't get my computer to recognize it. I have a MBP and a MBA. Same issue on both. Here is the message I get when I plug it in via USB, firewire, etc.

    [​IMG]

    The screen shot is not working. Basically it was a just a prompt that says "the disk you inserted was not readable by this computer."

    i don't know if it is physically damaged or what. I couldnt get the disk utility to open it and same with minitools.

    I couldn't care less about the drive itself but rather the data on it. I will probably trash the drive either way. However I would like to exhaust my options on trying to recover the data myself before getting it priced by professionals. Are there any suggestions on how I might extract the data without have to bring it to someone for hundreds of dollars?
     
  2. opinio macrumors 65816

    Joined:
    Mar 23, 2013
    #2
    Sounds like the drive may have given up.

    The Lacie controller could be gone though so you could take the drive out and try it on another controller (USB enclosure). If that doesn't work the it is likely the drive is at fault.

    If disk utility on two separate Macs cannot even pick it up then it sounds like something is damaged.
     
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    I've been in your situation myself. In my case I had a damaged and un-mountable partition with many mp3 files on it that I wanted to save.

    I tried numerous approaches, and could not get the partition to mount. Even a data recovery app like DataRescue could not access the drive because it could not be "seen".

    What to do next?

    Here's what worked:
    1. I re-initialized the drive into a single partition (yes, you read that correctly). However, I _DID NOT_ choose to "zero out the disk".
    2. The drive now appears "empty", but the old data is STILL THERE. This is because a quick re-initialization ONLY replaces the drive's directory. The data "out on the platters" is left intact.
    3. I then used "DataRescue" to attack the drive. DR "looks around" (i.e., ignores) the new directory, and "goes right to the platters" to scavenge, find, and then reassemble the data that is still "out there".
    4. DR found the files, and then saved them to a "scratch drive" (note: for data recovery to go smoothly, you MUST buy another drive to serve as your scratch drive).
    5. The recovered files no longer have the correct file names, because file names and folder hierarchies are a construct of the old directory, which was wiped out with the reinitialization. This is to be expected when you're doing data recovery.
    6. So... because the files I was attemping to recover were mp3 files, I dumped the entire lot of them into a "fresh" iTunes on the scratch drive. iTunes then read the metadata of the files (which survived the recovery), and was able to rename them!

    The above process worked for me when nothing else would.
    You WILL need another drive and data recovery software.

    Suggestion:
    Don't buy another "pre-packaged" drive. Instead, get yourself a "bare" drive and put it into a USB3/SATA "docking station". To see what these are, go to amazon.com and enter "usb3 sata dock" into the search box -- you will get many hits. They cost only $25 or less.

    I highly recommend a dock from plugable.com as a possible purchase (no financial interest other than being a paying customer).

    Data recovery will cost you some money (only a fraction of what you'll pay to have a professional service do the job, which could run into thousands of dollars), and will take some time and learning effort. But it is possible, when nothing else works (see above).

    Additional notes:
    The above process will work IF the drive involved does not have "hardware damage". With a drive that DOES have damaged hardware (i.e., heads, etc.) the only recourse is to pay to have a professional service disassemble the drive and recover the data. VERY expensive.
    Also -- the enclosure could have a problem. You might try taking the drive OUT OF the LaCie case, and putting it into a dock (see above), and see if it will mount there.
     
  4. g4cube macrumors 6502a

    Joined:
    Apr 22, 2003
    #4
    Before re-initializing the disk, you can try using Data Rescue on the drive, as it may be able to scavenge whatever is on the disk.

    Visit http://www.prosofteng.com/products/data_rescue.php
    The trial version should give you an indication of what might be recoverable.
    http://www.prosofteng.com/downloads/download.php?prodID=80

    If no success, or trying the bare drive in a dock another casing doesn't work, then professional data recovery should be considered if the data is important.
     

Share This Page