MBA Mid-2013 Shuts down randomly when lid closed

Discussion in 'MacBook Air' started by dimitryvin, Aug 20, 2013.

  1. dimitryvin macrumors newbie

    Jul 5, 2013
    Hey everyone,

    Just to start off, I am running the latest version of OS X Mavericks on my machine.

    Recently, when I leave my MBA's lid closed over night, there would be times where it just shuts off at some point at night. It doesn't happen every time, but it happens enough to become a bit annoying.

    When I open it up to turn it on, you can feel that it is a bit warm, as if the something was running overnight and I have to hit the power button a few times to get it up and running. I checked the shutdown logs and it says it gets a shutdown reason code 3. I've run a PRAM and SMC reset but it did not seem to fix the issue.

    Is this a software issue or is something up with my MBA?

    Thanks in advance.
  2. Steve121178 macrumors 601


    Apr 13, 2010
    Bedfordshire, UK
  3. Binarymix macrumors 65816

    Nov 1, 2007
    It's Mavericks.

    Had this happen a couple times, and even had my battery completely drain over night one night.

    Something went awry.

    Haven't had any issues since DP5 though.
  4. Mr Rabbit macrumors 6502a

    Mr Rabbit

    May 13, 2013
    More than likely software related.

    Previous Shutdown Cause numbers can be interpreted as follows:
    • Positive numbers (typically 0, 3, 5, etc) are user initiated actions, or at least the system thinks so. If these are showing up when you aren't initiating shutdowns, typically while it's asleep, then you almost always have a software issue.
    • Negative numbers (-128, -5, etc) show faulty shutdowns caused by hardware or loss of power. Bascially if you yank an iMac's power cord from the wall then go back and check the Console you will see a negative number.

    Since you're running Mavericks I would hold off on troubleshooting unless it continues after you've upgraded to the official release this Fall.
  5. dimitryvin thread starter macrumors newbie

    Jul 5, 2013
    Ok, thanks for the help guys!

    Though, it hasn't happened to me since I've disabled "Power Nap" in Energy Saver settings. Hopefully DP6 that has just released has fixed the issue.

Share This Page