MBA not charging

Discussion in 'MacBook Air' started by helveta, Oct 4, 2016.

  1. helveta macrumors member

    Joined:
    Mar 31, 2012
    #1
    I'm using a mid 2013 11" MBA on Yosemite 10.10.5. I use it all day at work plugged into a thunderbolt screen. This morning when I was using it at home not plugged in the laptop shut down because the battery was down. At work it runs and shows that it is plugged in in the upper right display but after half a day it still shows 0% charged. The light on the power cable isn't lit to show it charging but its working so its obviously getting power.

    What's going on? Any suggestions?
     
  2. ftaok macrumors 603

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #2
    Sounds like either the battery is shot or some part of the charging mechanism.

    Try downloading Coconut Battery and see if the battery is shot. Also, you might try bringing it to an Apple Store for them to look at (if you're lucky enough to have one close to you).
     
  3. helveta thread starter macrumors member

    Joined:
    Mar 31, 2012
    #3
    I got Battery Health from the App store. Coconut Battery wanted to instal too much junk ware. Battery Health says the batteries good, 95% healthy, 4856 mAh current capacity. Was out of the office for a couple hours with the computer on standby and now its 1% charged.

    No Apple store nearby.
     
  4. ftaok macrumors 603

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #4
    Sounds like either there's something wrong with the charging hardware on your MBA, or perhaps the charger itself is damaged.

    Take a look at the magsafe connections on the charger and the MBA. Look for anything obvious, like burnt connectors.

    If you can test with a different charger, that could eliminate a bunch of potential causes.
     
  5. helveta thread starter macrumors member

    Joined:
    Mar 31, 2012
    #5
    I'll have to wait until tonight to try the charger I have at home. Since the power is coming from the Thunderbolt monitor I don't think its a charger issue, although maybe its the cord? Anyway, its up to 4% now.
     
  6. ftaok macrumors 603

    ftaok

    Joined:
    Jan 23, 2002
    Location:
    East Coast
    #6
    Sometimes, I have to jiggle the cable to get the connection to "work". I'll come back and the light is off, not orange or green. And the battery won't have charged.

    Maybe that's all it is. Just jiggle it to make sure it lights up orange.

    ADDED - I found this on google. Maybe you have a similar issue.

    https://discussions.apple.com/thread/5520157?tstart=0
     
  7. helveta thread starter macrumors member

    Joined:
    Mar 31, 2012
    #7
    That was it. I had a spare adapter. When I traded it out the charging light came on. I'll have to play around when I'm not working and see if the adapters bad or just not connecting properly.

    Isn't it about time apple came out with a replacement for the Thunderbolt monitor. I like having my monitor as a hub.
     

Share This Page