MBA + Snow Leopard + sleep = Airport crashes

Discussion in 'macOS' started by jwflutterby, Sep 13, 2009.

  1. jwflutterby macrumors regular

    Joined:
    Jul 9, 2008
    #1
    I'm having an issue with my Air since I upgraded to Snow Leopard... Every time I close the lid and it goes to sleep, our Airport Extreme seems to die. We have 2 iPhones and a MacBook that also use the Airport Extreme and once the Air goes to sleep, none of the rest of the devices can find the Airport Extreme until we unplug it and plug it back in. The only workaround I've found so far is to turn off networking on my Air before I close the lid but this is annoying and I forget sometimes which mean everyone else gets booted until we restart the Airport Extreme... Has anyone else had this issue? Any ideas what might be causing it?? TIA!
     
  2. Acsom macrumors regular

    Joined:
    Jul 10, 2009
    #2
    I had the same issue; 2 mo old 17" MBP. it seems common, and I spent a fair amount of time searching for a solution. I found many people with the same issue, and several different solutions, none of which worked for everyone.

    I tried deleting the com.apple.internetconfigpriv.plist and com.apple.internetconfig.plist files; that made the problem worse. It would disconnect after a 5 minute pause in activity.

    An upgrade to 10.6.1 also made it worse.

    On the thought that it takes two to make a handshake, I reset my modem/router, a Westell 357, and restarted my Verizon DSL service from scratch. (WARNING: if you have Verizon, the Verizon installation package is incompatible with Firefox 3.5.3 and Safari 4.03. I found this out after I'd done the reset, and had to get a Windows laptop and use IE to do the setup.) I then went into the router properties and compared all the settings to the Airport settings, verifying that they matched.

    Since that time, about 16 hours ago, I've had no issues. I've done the sleep/open routine a couple dozen times, with varying intervals from a few seconds to 7 hours.

    I'm not sure why this worked; my guess is that it is related to the dynamic assigning of IP addresses by the router. The google search result that I find closest and most applicable to what I did is this one. So if what I did doesn't work for you, try that. There is a list of things to try at the end of that article; resetting the modem/router is on that list.

    I hope you get it to work, my friend.
     
  3. jwflutterby thread starter macrumors regular

    Joined:
    Jul 9, 2008
    #3
    Thanks for the suggestions! At first (before we realized it was the Air killing the router for everything else) we would reset our cable modem and the Airport Extreme every time this happened and it seemed to fix the problem, until the next time I closed the lid on my computer. Once we realized I was the killing the connection, we figured out that just power cycling the router fixed the problem. Now I know I just have to manually shut off my wireless connection before I let my Air go to sleep but there should be a better solution...

    Pretty much the only difference between my computer and the rest of the devices that connect and disconnect from the network at will without issue is that I do have a static IP. My Air does not seem to like DHCP, it likes to take whatever IP address it feels like whether something else is already using it or not but if I tell it something to use outside the range of the iPhones and other Macs and Xbox everything seems happier. This was an issue from day one though and was not new in Snow Leopard. It almost seems like my computer thinks it is the only device on the network, it takes whatever IP address it feels like unless I tell it otherwise and when it is done with the network, it's like it tells the router to sleep as well...
     

Share This Page