MBA Sound Issue Help!

Discussion in 'MacBook Air' started by DarioK, Aug 22, 2009.

  1. DarioK macrumors newbie

    Apr 10, 2009
    Barcelona, Spain
    I need your advice on this.

    My MBA 1.6 which I have had since feb 2008 no longer has sound. If I try to adjust the volume I get a circle with a line through it and in system preferences I have 'device has no output controls' showing. I checked online also resetting the PRAM which worked only a few times but now it doesn't. I am unable to find the solution....

    Some history: Earlier this year the hinges broke and after going back and forth with Apple they fixed it under warranty but at the time I was told that the logic board had also failed and so they replaced it.

    I mention this because some of the possible 'solutions' I have read elsewhere refer to the logic board needing replacement.

    Also a few weeks ago I tried out VMware Fusion with a legal copy of Windows XP, it had slowed my computer down considerably so I deleted it and all corresponding files but since then I have had no sound.

    Is it a hardware failure? Given that I was able to resolve it before with a PRAM reset and repaired permissions or is it a software failure? If so should I wait to upgrade to Snow Leopard on the hope that it will be fixed?

    All advice would be appreciated... I'm out of Apple warranty now but have store warranty for an extra year so should I return it or is there something I can do myself without opening the computer?

  2. wdean macrumors newbie

    Aug 22, 2009
    Boston, MA
    Same issue on my MacBook Air

    Hi Dario,

    I have a rev2 MacBook Air that I purchased new in November 2008 and the same thing happened to me about two months ago. I am just waiting for Snow Leopard to come out before having Apple fix it, since in both cases a clean install would be preferred.
  3. islesguy81 macrumors newbie

    Jul 23, 2009

    Sounds like an OS X problem
  4. Golden Master macrumors member

    Jul 7, 2007
    I've just had my rev A MBA repaired after suffering the same problem. It was a faulty ribbon cable and a quick google suggests this is quite a common problem.

    Some users report that a logic board replacement solved the problem. The tried this first with mine but tat wasn't the problem.

    If you're out of warranty, a quick google will lead you to DIY fixes and to the part that needs to be ordered.

Share This Page