MBA's USB port only putting out 500mA, need 900mA

Discussion in 'MacBook Air' started by kurtster, Apr 20, 2011.

  1. kurtster macrumors member

    Apr 12, 2005
    I just bought a LaCie Rikiki 1TB portable USB drive that keeps dismounting by itself while transferring large video files (up to 1GB). According to a review I read, it requires 900mA to spin up, obviously exceeding the 500 mA normally put out by a USB port.

    However, according to an Apple support page, the original MBA is listed among laptops having at least one USB port that can provide up to 1100mA for peripheral devices that may require more power.

    When I checked the System Profiler though, "Current Available Power" is 500 mA, and "Current Required Power" is 0 mA. There is no "Extra Operating Current" item as shown in the screen shot on the Apple page. So, obviously it's ejecting due to not drawing enough power.

    Is the MBA really capable of providing 1100mA? Currently, the Energy Saver preference for putting the hard disk to sleep is unchecked. Are there any other options I should know about?
  2. dime21 macrumors 6502

    Dec 9, 2010
    And now you know one reason why USB really sucks as a hard drive interface. Firewire provides 1500+ mA of bus power, easily enough for the largest and fastest drives to be bus-powered. Why Apple decided to omit Firewire from the MBA, I'll never understand.
  3. garfield2002, Apr 20, 2011
    Last edited: Apr 20, 2011

    garfield2002 macrumors regular

    Oct 31, 2003
    This should not happen even using USB 2.0. You might want to check the following.

    1. Try another >1GB file, the file could be corrupted.
    2. Transfer the file as a test to another external USB hard drive. If this succeeds then it is likely the Rikki drive that is the problem. If this also fails and you've tried step 1 then your MBA USB port might have a hardware problem. Or the USB cable could be faulty.

    Large files do transfer best to drives that are formatted in Apple HFS+ format. This makes the drive Mac only, but there can be problems if the external is formatted to Fat32.

    May be I should have asked this first, but is this a 2010 MBA or an earlier model? If it is a 2010, you can try and connect the USB plus the USB power cable, if this solve the problem it is indeed a power issue. My experience on a Rev.A MBA is that non-apple peripherals do not recognize that the USB port is higher powered and you'll need a powered USB hub, plus the USB power cable to get the drive to work properly. There is no work around as far as I know.
  4. Stingray454 macrumors 6502a

    Sep 22, 2009
    I've heard some people beeing able to use USB peripherals in one of the MBA's USB ports but not the other. I think there is a difference in the power output of the two ports. I don't have any information how much the ports can output though.
  5. hfg macrumors 68040


    Dec 1, 2006
    Cedar Rapids, IA. USA
    You might try the other USB port to see if it will work. The original Airs only had one port, but it was designed with more power output so as to be able to use the external USB DVD drive (which is why that drive only works with Airs and Minis ... other Macs don't have the power on a single port to run it). Current Airs have 2 ports, and are still compatible with the high powered external DVD drive (with a single USB plugin), but I have not seen any documentation that says both of the ports will power the drive. I haven't used my DVD drive with the new Air yet, but I would probably try the port nearest the power connector first (wild guess :) ).

    USB ports are "programmed" by the device to supply the required current for that device, and I believe that the maximum available from a "standard" USB port is 500ma.
  6. kurtster thread starter macrumors member

    Apr 12, 2005
    I forgot to say that I'm using the original MBA, so there's only one USB port to play with.
    I copied the same file (actually, a VIDEO_TS folder that contains a bunch of files) to my TimeCapsule and back again (and played it), so it's safe to say the file is not corrupted. Also tried to copy other stuff to the USB, and each time it ejects midway -- sometimes just after starting, sometimes right before the end.

    Regarding the use of two ports via a powered hub, according to this review, LaCie will provide a two-port cable for free. I'm in Japan, however, where service is handled not by LaCie but another company, but I'll call them up later today and see what they say.

    This morning I plugged in the Super Drive to check what the System Profiler would say, and sure enough, in addition to "Current Available Power" being 500 mA, and "Current Required Power" being 500 mA, "Extra Operating Current" appears on the following line and reads "600 mA".

    If that's the case, then it appears the LaCie drive is not doing its job, or else something else it happening, because it's not getting the "Extra Operating Current" that it needs, despite the USB port obviously being able to deliver it.

    I'm going to play around with the drive for another day or two, but if no dual-port cable is provided and I can't get it to work otherwise, I'll return it for something else that doesn't use bus power. Portability isn't a requirement.
  7. 2IS macrumors 68030

    Jan 9, 2011
    Because almsot nothing uses it and I doubt his USB drive would fit into a firewire port so it wouldn't have done much good anyway.
  8. ZipZap macrumors 603

    Dec 14, 2007
    I run a g-drive slim on either USB port on my MBA 13. No issues.
  9. garfield2002 macrumors regular

    Oct 31, 2003
    From your information I am pretty sure that the dual-port cable will get the drive to work.

    I also don't think that it's LaCie's fault in this case. As I recall there was a thread a while back with regard to getting third party USB DVD writers to work with the original MBA. It wasn't clear initially why the third party devices were not working properly whereas the Apple branded SuperDrive does. Someone disassembled the SuperDrive and found an extra chip that Apple used to tap into the extra power in the original MBA USB port. Sure enough rewiring the USB bridge from the SuperDrive to another third party drive allowed it to work properly.

    The 2010 Airs with dual USB ports don't seem to have this ridiculous problem.

    I have an original MBA and had to use the dual port cable on a hub to get my LaCie Sam Hecht designed DVD writer to mount.

    Best of luck. :)
  10. ZipZap macrumors 603

    Dec 14, 2007
    The OP posted about a HD not a DVD.

    BTW...There are a number of CD/DVD's that work fine with the Mac. The Superdrive was made by Apple to be proprietary so it would not work with anything other than an MBA. A pretty crappy thing for Apple to do.
  11. garfield2002, Apr 21, 2011
    Last edited: Apr 21, 2011

    garfield2002 macrumors regular

    Oct 31, 2003
    Thank you, the CD/DVD Burner was only an example a high current drawing USB device and a high capacity USB bus powered HD should operate on the same principle. It seems that in making the SuperDrive proprietary Apple also effectively limited the maximum current the USB port could provide to third-party devices. I was not able to find a CD/DVD writer that could be entirely bus powered on my Rev.A MBA.

    As far as I know these troubles only apply to the early generation Macbook airs. I don't know if this was corrected in Rev.B or Rev.C.
  12. rookiezzz macrumors regular

    Mar 21, 2011
    i think the problem is on your ext. hdd. i'm using 250gb seagate freeagent and 1tb wd passport w/o any problem, and i often transfer data more than 100gb at one time, but i always plug in the power into my mba first if i want to transfer that many, if just reading and writing a little bit, battery only is good..
  13. 2IS macrumors 68030

    Jan 9, 2011
    I'm inclined to blame the drive as well. I have 2 WD passport drives one is a 320GB and I believe the other is a 500GB and they both work using just a single USB port on my MBA or any other computer i've plugged them into. I've ran into a couple desktops where the front panel ports did not provide enough power but that's the only time I've run into issue.
  14. kurtster thread starter macrumors member

    Apr 12, 2005
    To follow up, I connected the Rikiki via a powered USB hub to the MBA, and also took it upstairs and tried it on my 2008 unibody Macbook (both USB ports thereof), but each time the self-dismounting issue continued. Also checked the System Profiler each time, and the "Extra Operating Current" item never appeared.

    Then called up LaCie's local support, which acknowledged a power issue with some computers, but said they couldn't supply a two-port cable as LaCie apparently does overseas (see review link above). The only fix they suggested was trying a powered USB hub.

    So, it was off to Bic Camera yesterday, where I exchanged the Rikiki for LaCie's Minimus 2TB drive. Last night I copied 500GB of files over to it without issue, so safe to say this one's a keeper.

    Gotta say I really like the Minimus -- VERY quiet, only slightly larger form factor than the Rikiki, similar brushed aluminum housing, and the extra mass prevents it from sliding around when a cable is accidentally tugged. Plus, the USB 3.0 gives me the option to upgrade to superspeed USB in the future on a different computer. As I mentioned above, portability isn't an issue, since it won't be leaving home. [In case you're wondering why I didn't get this in the first place, I simply didn't notice it in the sea of hard drives at the store].

    Anyway, regarding the Rikiki, maybe I had a lemon, or maybe it just doesn't work with the 1st gen MBA for whatever reason. Maybe it's really meant to be used in USB 3.0 mode (via a PCI Express Card or ExpressCard/34). Nevertheless, the Apple support page I linked to earlier clearly lists the original MBA among laptops having at least one USB port "that can provide up to 1100mA for peripheral devices that may require more power," so go figure.

    My advice to anyone planning to purchase the Rikiki for use as a USB 2.0 drive is to save your receipt.
  15. mrsir2009 macrumors 604


    Sep 17, 2009
    Melbourne, Australia
    Next refresh when Thunderbolt goes it you'll hopefully be able to use that for external HDDs.

Share This Page