MBP 13 2020 & LG 4K Ultrafine connectivity issue in video calls.

roy61

macrumors newbie
Original poster
Jun 11, 2020
6
0
Hello, wondering if anyone has experienced the same issues I'm having with my MacBook Pro 13 2020, i7 32GB 2TB & LG 4K Ultrafine Display.

When I am connected to the display and if I am in a video call (whereby, zoom, webex are the ones I've tried) and sharing screen, after about 10-15 minutes the connection between display and Mac goes in and out. Both screens turn black repeatedly. It's almost unusable. This happens mostly when I'm sharing my screen but somethings even when I'm not.

This is the second MacBook Pro with the same configuration and the first one also had the same issue. There were other problems with that machine so I exchanged it for a brand new one and same thing.

Previously I had a MacBook Pro 13 2018 i7 and connected it to 2 LG 4K Ultrafine and never once had a connectivity issue like this. Now I'm only connected to one display. Tried swapping Thunderbolt cables and all the USB-C ports.

There may be something wrong with the display itself but I thought I would see if there's anyone who has experienced the same thing.

Thank you.
 

roy61

macrumors newbie
Original poster
Jun 11, 2020
6
0
It might be memory bandwidth issues with the iGPU.
Thanks for the reply, you mean it's might be something inherent with the iGPU on the i7? I was thinking it might be something like that because it seems to only occur after a prolonged period of time when doing video calls.
 

pshufd

macrumors 68020
Oct 24, 2013
2,033
2,541
New Hampshire
Thanks for the reply, you mean it's might be something inherent with the iGPU on the i7? I was thinking it might be something like that because it seems to only occur after a prolonged period of time when doing video calls.
I have a 2014 MBP with Intel integrated graphics and I used to hook it up to 2 QHD monitors. I found that I would get video artifacts if I was doing memory-intensive operations (like doing an SSD to SSD copy). I bought a 2015 MBP 15 with Discrete Graphics and don't have this problem. I currently run Dell 4K + Dell QHD monitors off a 2015 MBP With Radeon graphics and have no video artifact issues.

I do not know if this is your problem but it kind of reminds me of the problems that I used to have. In general, I prefer discrete graphics if at all possible.
 

drxcm

macrumors regular
Nov 2, 2010
206
44
2020 10th gen i5 / 32gb / 1tb with LG 4k (23") ultrafine here

Have had no issues. Zoom to 400 people with me screen sharing last week for an hour - no issues.
I also do regular zoom meetings 3-4 times a week since I've had it with no display dropouts

Hope that helps
 

roy61

macrumors newbie
Original poster
Jun 11, 2020
6
0
2020 10th gen i5 / 32gb / 1tb with LG 4k (23") ultrafine here

Have had no issues. Zoom to 400 people with me screen sharing last week for an hour - no issues.
I also do regular zoom meetings 3-4 times a week since I've had it with no display dropouts

Hope that helps
Thanks, good to know. Might need to test on another display.
 

biffuz

macrumors member
Feb 23, 2016
83
52
Sounds like a cable problem to me, try a better quality one. Also try to use a grounded power cable, not the simple plug adapter.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.