MBP 13" battery draining while on AC Power????

Discussion in 'MacBook Pro' started by jmazzamj, Jun 24, 2010.

  1. jmazzamj macrumors regular

    Jun 11, 2009
    Hi everyone. I have checked MRoogle with no luck and I really really hope you can help me out with my battery issue.

    The title says it all, basically my MBP's battery drains even if the computer is plugged. When I sat at my desk to use my MBP earlier today I noticed the battery was charging. That seemed very weired, I was sure it was at 98% last night. I decided to switch my computer off and let it charge all the way up.

    When I turnt on my computer again i checked the battery and everything seemed normal, but after half an hour or so I noticed that my battery status icon had chaged from charged to not charging.

    I loaded up Coconut battery and the battery was slightly over 90%...and it's still draining out while tipyng...

    The AC socket is fine and I have an HDTV connected to the same power source. Needless to say the tv is working normally...

    Any advice? I do not have an Apple shop nearby, the closest is over 200 km (approximately 140 miles) away.

    Cheers from Italy...

    EDIT: I have reset the SMC with no luck.
  2. trfjason macrumors member

    May 28, 2010
    I think it is normal for the battery to self discharge. My MBP is plugged into an AC outlet for most of the time and the battery % does decrease over time even on AC power. In my case, after the MBP is charged to 100%, the % decreased to 95% despite that I only used it on AC power.

    The MBP will not charge the battery unless the capacity is less than 95%
  3. djasterix macrumors 6502a


    Apr 10, 2010
    Paradise City
    That's normal with this new batteries, we just have to get used to...
  4. jmazzamj thread starter macrumors regular

    Jun 11, 2009
    Hi guys and thanks for your replies but I can assure you that this specific issue is not normal.

    My battery charge decreased over 20% in less than one hour while connected to AC and I only had Safari with few tabs and Mail running.

    Im currently calibrating the battery...I hope this helps.

    Thank you again.
  5. jmazzamj thread starter macrumors regular

    Jun 11, 2009
    Hi everyone.

    Resetting the SMC after a battery calibration seems to have solved the issue.

    Thank you

Share This Page