MBP (13", Late '11) keeps ejecting USB flash drives

Discussion in 'MacBook Pro' started by HBNorm, Dec 26, 2014.

  1. HBNorm macrumors newbie

    Joined:
    Dec 26, 2014
    #1
    I have a MBP 13" late 2011 upgraded to Yosemite that constantly ejects and remounts flash drives that are connected to either USB port. Ejections occur as I'm trying to copy from or write to the flash drive.

    At first I thought it was a hardware issue but when rebooting into Windows 8.1 64-bit, both USB ports function just fine. Also, when in OSX, USB external hard drives seem to work fine (e.g., when backing up via Time Machine). I have the same ejection issue with USB flash drives that are old and brand new and 100% Mac compatible. Any guidance would be greatly appreciated. It's driving me insane!

    Thanks and Happy New Year!

    Norm
     
  2. HBNorm thread starter macrumors newbie

    Joined:
    Dec 26, 2014
    #2
    Seems to be related to larger cards/USB drives

    Used a small 2gig card in a reader with no problems. However, a 32 gig card in the same reader, big problems! Same 32 gig card via my GoPro and same usb port, no problem. Also, ejection issue with my brand new 32 gig "Mac compatible" USB flash drive but no issues with my 8 gig and smaller USB flash drives. Insanity! <:-0
     
  3. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #3
    Hi,

    just in case, I would do an SMC reset : the SMC handles the USB ports power supply.
     
  4. HBNorm thread starter macrumors newbie

    Joined:
    Dec 26, 2014
    #4
    Tried SMB Reset To No Avail

    Thanks for your input Bruno. I reset the SMB but still have the issue. It seems to be limited to large flash-based media connected via the USB ports. Once again, there are no issues with the USB ports when I'm booted in Windows 8.1, just Mac OSX Yosemite.

    I just moved the 32gb micro SD into a full size SD adapter and that worked just fine. It's via the USB ports where the issue occurs. Strange...
     

Share This Page