MBP 13" USB Port Audio Issue

Discussion in 'macOS' started by SweeneyD24, Apr 24, 2012.

  1. SweeneyD24 macrumors regular

    SweeneyD24

    Joined:
    Feb 16, 2011
    Location:
    Mauritius
    #1
    Hey guys!

    I've been using the Logitech S150 Digital USB Speakers on my MBP 13" for over 1 year now and it worked fine till recently!

    The speakers were plugged in the first USB port (between the second USB port and the card reader slot)! Everything was working perfectly until recently when i couldn't get any sound to come out of the left speaker, only from the speaker on the right (as if the audio was panned to the right only). I used the other USB port and it worked perfectly!

    I'm found somewhere that it might be related to some kind of power delivery difference between the USB ports!

    Has anyone experienced this?
    Any advice on how to fix this!?

    Thnx!!

    --
    MBP 13" Mac Os X Lion 2.26Ghz, 160GB HD, 2GB Ram; iPhone 4S 64GB
     
  2. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #2
    Apple considers the first port to be the one you're calling the second port (the one away from the SD card slot). It is capable of providing High-Power USB, so yes, there is a difference. I wouldn't have expected it to be needed for those, but there is some difference in the two ports.

    jW
     
  3. SweeneyD24 thread starter macrumors regular

    SweeneyD24

    Joined:
    Feb 16, 2011
    Location:
    Mauritius
    #3
    So i'm having issues with the second port then!!
    OK, but like i said, the two ports worked fine until recently! I just want to know what's going on, and how to fix this!
    Thnx anyway for the info!
     
  4. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #4
    When you have the imbalance, go into System Preferences -> Sound -> Output and make sure the "Balance" slider is in the center.
     
  5. SweeneyD24 thread starter macrumors regular

    SweeneyD24

    Joined:
    Feb 16, 2011
    Location:
    Mauritius
    #5
    That's not exactly the problem here!
    Anyway, thnx for the concern! :)
     

Share This Page