MBP 15" i7 install OS X from flash drive

Discussion in 'MacBook Pro' started by calvy, Jun 3, 2010.

  1. calvy macrumors 65816

    Joined:
    Sep 17, 2007
    #1
    Ok, so I just got this brand new i7 Macbook Pro a week ago from the Apple store. Today I got in the mail my hard drive bay replacement for the optical slot in the macbook pro from newmodus, and I went to install it. Got the parts in and hooked up, and I'm trying to install my OS onto the Intel X25-M SSD drive that I've got in the primary hard drive spot. I have a flash drive that has an image of Snow Leopard on it, that I recently used to do a fresh install on an older Macbook Pro, so I know it works. But when I boot the machine up with this flash drive, it sees the drive in my boot menu, but when I select it it just stops. Shows the apple logo on the white screen for hours if I let it. I can boot just fine to my old hard drive which is now in the place of the Optical drive. When I look at the flash drive from within the OS on my old drive, it shows fine, and I click the Install link, and it goes through the installer. But then when it wants you to reboot, you reboot and it hangs again trying to boot the flash drive. I've tried it now with two different flash drives, same result.

    Anyone have any idea why this is happening? I'm frustrated now so I'm going to take a walk and come back to it in a little bit. Only option I can see at this point is putting the optical drive back in and installing from a CD to see if that works fine.
     
  2. bugout macrumors 6502a

    Joined:
    May 11, 2008
    Location:
    is everything!
    #2
    Your new macbook pro has a newer build version of snow leopard, it won't install an earlier version. You have to make an new image of the DVD's that came with your new macbook pro on the flash drive to do the installation.

    The snow leopard versions won't be in alignment until the next .(dot) release, i.e. 10.6.4
     
  3. calvy thread starter macrumors 65816

    Joined:
    Sep 17, 2007
    #3
    Guess I'll just install via the discs that it came with then. I should note that the image I was using was from a retail DVD of snow leapord, not a version that shipped with a previous machine. However, I could see how a newer dot release could be necessary. Just surprised that it won't boot at all.
     

Share This Page