MBP 15 inch 8600gt fail?

Discussion in 'Mac Basics and Help' started by Theclamshell, Feb 24, 2010.

  1. Theclamshell macrumors 68030

    Joined:
    Mar 2, 2009
    #1
    So i have a macbook pro 2.2Ghz with a 128Mb 8600 gt. The screen displays no video nor does an external monitor. However, i can connect to it thought screen sharing and it works fine.

    One weird thing though is that it in system profiler, it says the graphics card in a gma x3100 with 64Mb of ram. One other wierd thing is that it does not seem to even recognize its own lcd screen (see pic) One final thing, Will apple still fix it if the computer has been opened for an Hd replacement i made?
     

    Attached Files:

  2. Thiol macrumors 6502a

    Thiol

    Joined:
    Jan 26, 2008
    #2
    That is weird and probably needs repair.

    Replacement of a hard drive does not void your Applecare.
     
  3. Theclamshell thread starter macrumors 68030

    Joined:
    Mar 2, 2009
    #3

    Thanks for the quick reply, Im pretty sure this is covered under warranty. This is correct, right?
     
  4. lag1090 macrumors 6502

    Joined:
    Jan 28, 2007
    Location:
    NJ
    #4
    Yep, it's almost certainly a graphics card failure. The same issue has happened to me twice so far on a 15", mid-2007 MBP.
     
  5. steve2112 macrumors 68040

    steve2112

    Joined:
    Feb 20, 2009
    Location:
    East of Lyra, Northwest of Pegasus
    #5
    Funny this thread should pop up, since the 8600 GT in my work Macbook Pro failed Friday. When mine failed, it failed completely. I had no video on the display or on an external monitor. I didn't try screen sharing, though. They agreed to replace it, even though the machine is no longer under AppleCare. Mine has an aftermarket HD and RAM, and they didn't say anything about it.
     
  6. Thiol macrumors 6502a

    Thiol

    Joined:
    Jan 26, 2008
    #6
    Correct.
     

Share This Page