MBP 15" won't boot off external drive

Discussion in 'MacBook Pro' started by zuurbekje, Jun 6, 2010.

  1. zuurbekje macrumors newbie

    Joined:
    May 22, 2010
    #1
    To regularly run tools like DiskWarrior, I have an external hard drive that will make my machine boot in root user, 10.6—which is a fine facility to have.

    But now my MacBook Pro 15" (unibody, Mid-2009) won't boot up anymore off my external drive. For full disclosure, I should now add that I have not one but two of such external drives—and both don't work, while they still boot my 2007 MacBook and Intel iMac just fine. It makes no difference whether I try to use ALT during startup, or adjust the Startup Disk once booted up from the internal drive, in System Preferences. It also makes no difference whether I use the drives' FireWire or USB ports.

    So, what now? Time for a new motherboard, or... Anyone have a suggestion?
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
  3. zuurbekje thread starter macrumors newbie

    Joined:
    May 22, 2010
    #3
    Thanks for the swift reply! Unfortunately, that didn't do it for me.
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    Are the HDDs at least recognized in Mac OS X and DIsk Utility?
     
  5. zuurbekje thread starter macrumors newbie

    Joined:
    May 22, 2010
    #5
    Sure, they're fine. They show up in the Finder, in Disk Utility, when booting with ALT, and in the Startup Disk preference pane. Also, my other intel Macs still boot fine off of them.
     

Share This Page