MBP 17" 2010 RAM Upgrade

Discussion in 'MacBook Pro' started by nemeesys, Oct 17, 2015.

  1. nemeesys macrumors newbie

    Joined:
    Oct 17, 2015
    #1
    Hello all, I've been reading forums, blogs, and sites for a couple days about this issue but one thing never gets mentioned so I thought I would throw it out there and see if there's an answer.

    As the post title suggests, I have 17" Mid-2010 that came stock with 4GB. I bought 16GB (2x8) of RAM from OWC thinking that it would work because other mid-2010s seem to be able to upgrade to that. It doesn't and doesn't seem like that's possible because my proc is an i5. I get it, my bad. I blame no one but me for not reading the fine print.

    However, I can put the RAM in and Yosemite runs just fine...up to a point. In "About This Mac" it reports 16GB. If I have Activity Monitor up, I can watch the memory usage and it will crash just as it hits 4GB. The exact amount that this machine came with. That's just too much of a coincidence for me to buy. I flashed my NVRAM just in case a value for available RAM was stored there. That didn't help. Seeing as how it's possible to upgrade this model to 8GB, why doesn't it crash at the 8GB mark? Why always at 4GB (this is reproducible every time)?

    Thanks for any thoughts on this.
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Take each stick out one at a time and see if it still occurs, you might just have a bad module.
     
  3. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #3
    The max for your model is limited to 8gb. 4gb per channel.
     
  4. nemeesys, Oct 18, 2015
    Last edited: Oct 18, 2015

    nemeesys thread starter macrumors newbie

    Joined:
    Oct 17, 2015
    #4
    Thank you both for your replies so far.

    I should have mentioned that I tried that.

    As noted, I figured all that out. But that doesn't answer my actual question. If it crashes at the 4GB mark then that sort of implies that RAM is filled up one channel at a time and when it hits the chipset limit then it causes a kernel panic. But I didn't think it worked that way (where one stick of RAM fills up first before moving on to the next and so on). It also begs the question why does the system report 16GB? As a programmer, I always try to code to the possible. So if I can't access something I A) don't report that it's there and B) don't try to access it. See what I mean?

    EDIT: Btw, I'm not really complaining about this issue. I'm just trying to understand it better. I became a programmer because I'm curious and I like to tinker. o_O
     
  5. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #5
    Honestly I think it's to do with both chipset limitations and changes in chip density. The knock on effect is one channel gets dumped by the chipset and the other cant be populated past its 4gb limit
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    I am pretty sure that your MBPro is limited to a maximum of 8GB. And, you have two slots, so each has an upper limit of 4GB.
    Hence, if you have a single 8GB stick installed, it boots (after a fashion), and knows how much is installed. But, can't address (actually use) more than 4GB per slot.
    So, the single 8GB sorta works, but not much.

    The only mid-2010 MBPro that accepts that 16GB is the 13-inch, which doesn't have an i5 or i7, but still uses a core 2 Duo. That's one that I don't quite understand, either!

    Upgrade RAM to 2 x 4GB, and you'll be good.
     
  7. nemeesys thread starter macrumors newbie

    Joined:
    Oct 17, 2015
    #7
    It is. Every source says so. And I've ordered my 2x4GB sticks from Crucial. I was more wondering the detailed cause of the behavior in my original post. But thanks.

    From what I've read the limitation is definitely caused by the mobo chipset. It might be that both channels are getting memory dumps but then one channel gets asked to go above the 4GB, the chipset raises a flag, and the kernel panics. Just very odd lining up of coincidences/numbers.
     

Share This Page