MBP 2009, epic bootcamp problems (XP)

Discussion in 'Windows, Linux & Others on the Mac' started by bonusballer88, Aug 18, 2011.

  1. bonusballer88 macrumors newbie

    Joined:
    Aug 18, 2011
    #1
    hi

    so for the past one and a half days.. straight. i have been trying to re-bootcamp my MBP with windows xp sp3.

    originally, i was running windows 7 rc (the beta version that was free) because i happened to purchase my MBP right when rc was released. it worked.. i made an .iso, burned it to a cd on my old pc, and then ran bootcamp perfectly. that was 2 years ago.

    recently, i finally decided to just get xp because of complications with rc 7.

    so i looked up which xp product to buy.. non-OEM, 32 bit, FULL windows XP professional sp3 and then i got the cd but every single time, when i click "start installation," boot camp assistant will display: (The installer disc could not be found.)

    this wasn't so frustrating the first 10 times.. but after 200 or so it gets to you.

    i tried burning a copy of my brand new windows XP, which worked perfectly on my old desktop.. leaving me with 12 coasters.

    i tried restoring and re-creating a 32gb (supposed to use this), 8gb, 64gb partition for windows, but this doesn't help.

    i tried putting in the xp disk, restarting, and holding option/c/various combinations of keys.

    i tried verifying my entire hard-drive. no errors.

    i am seriously frustrated about this because i have literally clicked on every google search pertaining to this and the results are, either A. they didn't figure out how to get past this and just gave up. or B. somehow, by some miracle, their mac decided to stop messing with them and to just install windows.

    TLDR - i can't get past the boot camp assistant's "start installation" button.

    i can partition/re-partition as much as i want but my mac just WILL NOT read the disk for some reason.

    this isn't a problem with other cd's, however, because i was able to rip songs from another cd when i was checking if the drive was messed up.

    please! i need suggestions on what to do.. i don't know what else i can possibly do to make this work..

    should i just get windows 7??

    also.. i checked my boot camp assistant version: 2.0. is this a problem? i looked up on wikipedia and it says boot camp version: 2.1 is windows sp3 supported.

    thankyou!!!!!!!!
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    What happens when you load the disc in the drive and reboot holding Alt/Option? Does it come up with the boot selector or not?

    We can deal with the drivers later....

    B
     
  3. bonusballer88 thread starter macrumors newbie

    Joined:
    Aug 18, 2011
    #3
    hey tiger guy (i saw your avatar a lot when i was looking for fixes)

    i FINALLY FIXED IT!!!!!!!!!!!!!!!!

    it wasn't a matter of damaged data or inappropriate steps.

    i eventually decided to try a simple audio cd because i suspected the drive was broken and lo and behold, it refused to read my audio cd.

    i tried various dvd's as well (i NEVER use my disk drive.. so i didn't know) but they all didn't work.

    i found out that some firmware upgrade might have caused this.. or there might just be a ton of dust.

    so i took a micro-fibre cloth, wrapped a credit card with it and brushed the inside of the superdrive somewhat vigorously. then i sprayed the inside with compressed air and BAM!!!!!!!!! IT READ MY CD WOOHOO!

    as you can see i am absolutely ecstatic.. and kind of disappointed that dust ended up being my mortal enemy.

    anyway, hope this helps a lot of other people.. we tend to overlook the simple things. or maybe just me.
     

Share This Page