MBP 2011 deep sleep issue

Discussion in 'MacBook Pro' started by thierrz, Feb 14, 2013.

  1. thierrz macrumors newbie

    Joined:
    Jul 25, 2012
    #1
    MacBook Pro Mid 2011 13"
    i5 2,4 GHz
    OS X 10.8.2
    4 GB RAM


    Hi all! I have a problem with my MacBook Pro regarding the deep sleep mode. Normally when you close the lid, the MacBook goes into sleep modus. When you open it, you're back in a second. When you don't use the MBP for a couple of hours, it goes into deep sleep.

    I wanted it to put it manually to deep sleep, so I downloaded the deep sleep widget.
    (this one: http://www.apple.com/downloads/dashboard/status/deepsleep.html)

    It went into deep sleep but when I tried to wake it, it got stuck at the loading screen. It then made 3 *beeps*, repeatedly and I had to turn it off and then turn it on again.

    So I tried some terminal fixes, but now it won't even go to deep sleep anymore.

    Here is what I did in this order:

    Removed the deep sleep widget

    Terminal: sudo pmset -a hibernatemode 0
    rm /private/var/vm/sleepimage

    Set back to: sudo pmset hibernatemode 3

    Pram - PMC Reset

    Reinstalled OS X

    None of this fixed the problem.

    So now my MBP won't go into deep sleep mode, and I don't know why.

    Is there anyone who knows how to fix this or provide me with any tips or pointers?

    Thanks in advance!
     
  2. BlooBamboo macrumors newbie

    Joined:
    Oct 29, 2008
    #2
    Just saw this question and wondered what version of the Deep Sleep widget you are running. The original (version 1.2) causes Mountain Lion to crash because the numbers changed for the hibernation modes.

    There is an updated version (1.3) available here
    https://github.com/code2k/Deep-Sleep.wdgt
     

Share This Page