MBP 2011 i7 Infinite Problems Since Thunderbolt\EFI Update

Discussion in 'MacBook Pro' started by heyadrian, Aug 14, 2011.

  1. heyadrian macrumors member

    Joined:
    Aug 14, 2011
    #1
    Hi,

    Ive had my MBP 2011, i7 for several days now and it was going well until I had updates come up for Thunderbolt (something like that), SMC\EFI?

    I clicked to reboot & install and decided to wait it out as they were small.

    After about 10 mins it was still stuck at the gray apple screen with the spinning wheel below it.

    I then decided to leave it at that for the day, went out for about 8 hours came back and it was still there?

    (I know you shouldnt) but I turned it off and fired it back up.. It came up and 2 seconds later powered down.

    Since this time I've:

    1) Tried safe mode (left shift), same result
    2) Tried Command + S and did a fsck and it came up wuth invalid node structs. So booted off the install disk and disk utility found issues and wouldnt repair
    3) Tried DiskWarrior, and that didnt like it any more, just booted so far and halte with 3 beeps (repeatedly - usualy denotes memory issue, but the beep codes ONLY happen with DW)
    4) Decided to install to an external drive. Which went well until I first logged in. NOTHING worked, only the dock. With an error "finder quit unexpectedly" ignore does nothing. None of the apps work. Did another disk utility check and all was well on that drive other than the permissions.
    5) The pup decided t chew the bloody external drive cable in the process so that a no-go now
    6) Booted off install CD again, removed the partition, added another, gave it another name (just incase) and set it to Extended \(journalled) and zero wrote it. Did a verify, and there were node issues?! Did a repair, and it fixed something, verified again, and it was ok. (This was odd as I had just cleared the lot? ANy clues here?)
    7) Installed OSX 10.6.7 again, fired it up, dock there, everything else dead as in (4) above. Did the same thing, and same problems.
    8) checked /private/var/log/install.log to see what was there, and woah betide me there were OLD entries from previous installs? Regardless whether or not I nuked and zerod the pertition.
    9) Tried an SMC/PRAM reset, did nothing
    10) Did a hardware test (which I did when I first got the "craptop" which passed all on the extended) and as soon as I pressed "test" on te quick test, it hung on memory. I did try memtest86 from another boot CD which I use and it was happy with the mem after 10 extensive passes.

    My questions are: Is there a bootable way I can reinstall the "stock EFI and SMC and Thunderbolt" firmware, have I missed out any testing steps or other "resets" like SMC\PRAM?.

    And where is a good source of valium as I'm on the edge of a vervous breakdown!

    I hope you guys can help :)

    Thanks

    Adrian

    Edit: Excuse all the weird slashes etc...as you can see I'm not too accustomed to windows laptops!! Someone save me from the abyss!
     
  2. heyadrian thread starter macrumors member

    Joined:
    Aug 14, 2011
    #2
    To add to the above. I've had numerous installation errors... These DVDs work fine on the other halfs machine. lol she wasnt too happy about me nuking her windows partition, but hey, after all thats what it deserved haha.

    I've had "Unable to copy support files part way trough install, as well as, when you should get the "Installing" with the big X, you get a gray background, but it still sounds like its installing as the DVD is going nuts.
    And sometimes at the end it comes up with a huge error dump\log. When looking through it.

    I did notice that the last tie I installed it, first time it ran fine, then 10.6.8 update murdered it... Wen I did a DU check all the permissions were cooked ... permanently...
     
  3. Macsavvytech macrumors 6502a

    Macsavvytech

    Joined:
    May 25, 2010
    #3
    So a clean install is still causing you issues?
    At this point I would be taking it to apple and asking them about it, sounds to me as I'd you have had incredibly bad luck and may have had something fail during the EFI update. I am not sure if there is a bootable EFI updater. If you erase the whole drive and retardation it and the problem still exists then it really only leads to some form of hardware problem.
     
  4. heyadrian thread starter macrumors member

    Joined:
    Aug 14, 2011
    #4
    Hmm I think it more to do with the update.

    Is there no way I can mount the dmg & install the pkg from the installer CD? Maybe forcing the update to run again might help. I cant mess it up any more than it already is lol
     
  5. broadsword macrumors newbie

    Joined:
    Nov 11, 2010
    Location:
    Los Angeles
    #5
    Your machine is brand new. Use your warranty and free phone support. Let Applecare help you out of the ditch. It's your best option.
     
  6. heyadrian thread starter macrumors member

    Joined:
    Aug 14, 2011
    #6
    yeah I've placed a planned callback, but being the Director of an IT Solutions Provider drives me to want to know what the issue is :-D
     
  7. heyadrian thread starter macrumors member

    Joined:
    Aug 14, 2011
    #7
    Looks like the Harddrive\hardware wasnt cooked after all. I think that it had something to do with that EFI partition.

    What I did was literally scrap the disk partitions (all three)using a third party disk manager, booted back off te OSX Install DVD, made the partitions using DU, installed, fixed.

    Its a little annoying that was the only way about it... EFI Updates DONT only happen on-board, but they also write various info to the harddrive. Namely the EFI partition.

    I guess thats where it went wrong...
     
  8. heyadrian thread starter macrumors member

    Joined:
    Aug 14, 2011
    #8
    just to add to this and draw a line under it, it died again some time later on with the same problems. It turned out to be a logic board issue.. Oddly enough, the Apple Store (and not the supplier) replaced it. Either way I got it back and it's been working flawlessly to date :)
     

Share This Page