MBP 2011 Permissions

Discussion in 'MacBook Pro' started by Shrump, Oct 8, 2011.

  1. Shrump macrumors newbie

    Joined:
    Oct 8, 2011
    #1
    Earlier, I was using my 2011 MBP, when suddenly an error popped up telling me the computer needed to restart and that I needed to hold down the power button to do so. This is a picture of the same error I received

    [​IMG].

    I followed the instructions, but the first time it tried to boot up, during the process of booting, text appeared on screen alongside the same error as above. (I cannot provide a picture of this, because I can't accurately recall what it looked like and thus am unable to provide an accurate visual representation) After I restarted it again, and it booted successfully, I noticed some odd changes.

    For one, I was unable to open iTunes. An error popped up saying, "The iTunes application could not be opened. An unknown error occurred (13014)."

    Secondly, Spotlight was indexing files on my drive. After it was done, no matter what I searched, no results came up.

    Thirdly, Firefox no longer stored history, nor did it have any stored bookmarks or history. I couldn't choose to go back to the previous page. If I closed Firefox, then tried to open it again, it comes up with an error saying an instance of Firefox is already open and only once copy of it can be open. These results can be replicated even if I thoroughly quit out of Firefox.

    Fourthly, I was unable to delete files. An error saying "The operation can’t be completed because an unexpected error occurred (error code -50)." popped up.

    Fifthly, when I tried to change setup options of Ventrilo, errors popped up saying "Unable to create password file" and "Unable to write INI file".

    Lastly, I couldn't save downloads or even Microsoft Word documents for that matter. I could however open documents and applications.

    I have tried searching online for any possible solutions. I tried restarting my laptop. The first time I tried, permissions to my files were restored temporarily before reverting back after a few minutes. I tried using Disk Utility to verify and repair the disk permissions.

    When I tried repairing the disk permissions, I got things along the lines of:
    Group differs on "Applications/Utilities/AirPort Utility.app/Contents/Resources/pl.lproj/AirPortUtilityHelp/gfx/godormroom.gif", should be 0, group is 80.
    Permissions differ on "Applications/Utilities/AirPort Utility.app/Contents/Resources/pl.lproj/AirPortUtilityHelp/gfx/godormroom.gif", should be -rw-r--r-- , they are -rw-rw-r-- .
    Unable to set owner and group on "Applications/Utilities/AirPort Utility.app/Contents/Resources/pl.lproj/AirPortUtilityHelp/gfx/godormroom.gif". Error 22: Invalid argument
    Unable to set permissions on "Applications/Utilities/AirPort Utility.app/Contents/Resources/pl.lproj/AirPortUtilityHelp/gfx/godormroom.gif". Error 22: Invalid argument

    Can anyone identify this problem? If so, how can I fix it?

    Thanks in advance.
     
  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
  3. salacious macrumors 6502a

    Joined:
    May 15, 2011
    #3
    back up your important data and re-install, or take it to an apple store, im not a genius on macs but thats just my 2 pence
     
  4. blatopilot macrumors regular

    Joined:
    Sep 24, 2011
    #4
    Backing up files is a crucial first step.

    Can you install files via USB? One (free) program I found helpful for things like this is Applejack. If your hard drive is okay, its worth a shot.

    You install it, restart your computer holding CMD +S. That boots you into single user mode. It will load some text then allow you to type. For simplicity, use "applejack AUTO restart". AUTO in caps does a deeper clean.

    It will run through some processes and then restart your computer.

    http://newmacuser.com/apple-jack-helps-repair-permissions-and-so-much-more/
     

Share This Page