MBP 2012 17" No Wifi Hardware (after replacing the card)

Discussion in 'MacBook Pro' started by slvrscoobie, Jun 12, 2019.

  1. slvrscoobie macrumors 6502a

    slvrscoobie

    Joined:
    Mar 24, 2013
    Location:
    NJ
    #1
    Hey guys and gals.
    Weird thing happened to my MBP the other day. I was using it to check out my ADB-S webpage and i got up to get a drink. I sat back down and chrome said there was no internet.
    Sure enough i look at the wifi icon and its black with an X. (if i recall correctly) - says its turned off.
    Hmm, ok, try to turn on, no dice.
    Ok, reboot.....
    Now its a pie shape with an x in the middle and hovering says 'No wifi hardware installed'
    Well crud!
    Reset SMC + NVRAM
    same thing
    Open it up, wiggle the cable...
    Still no
    replace the airport card with one from my wifes 15"
    nothing
    dang it! - ok, cable must be bad. I still have BT but no wifi. (why couldnt those be reversed)
    Buy a new cable and card on ebay. They arrived today. Installed, reset SMC And NVRAM
    Still 'No Wifi hardware installed'
    Im hoping this isnt like a motherboard issue now...
    things of note: I had the continuity hack installed with the newer 4ACX card for .. 3 years? I uninstalled it today to see if the new card / cable would work if i uninstalled that. it didnt change anything.
    Im out of ideas and searching just brings up replacing the card or SMC resets.
     
  2. currahee2100 macrumors regular

    Joined:
    Feb 9, 2009
    #2
  3. slvrscoobie, Jun 12, 2019
    Last edited: Jun 12, 2019

    slvrscoobie thread starter macrumors 6502a

    slvrscoobie

    Joined:
    Mar 24, 2013
    Location:
    NJ
    #3
    oh and the BT seems to work fine...
    --- Post Merged, Jun 12, 2019 ---
    It did not, which is why i thought it must be the cable...i just tried with her card and the new cable, still nothing.
    it was an ebay apple card - said it was from a working machine. $10 for an old card, and ribbon cable, looked fine, other than some dust when it arrived. I also pulled the ribbon cable from my 13" mac and plugged it in to test, and still nothing...
    I bought a 2nd card and cable from Ebay, maybe i got a bum card / cable. I tried to swap em around (old card, new cable, and new card old cable too). but im not sure i reset everything between there.
    Im starting to lean towards the bad mobo connection or something :(
     
  4. satinsilverem2 macrumors 6502a

    satinsilverem2

    Joined:
    Nov 12, 2013
    Location:
    Richmond, VA
    #4
    There’s no such thing as a 2012 17” model. The last model for the 17” was the late 2011
     

Share This Page

3 June 12, 2019