Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
June 2012 MBP 2.6Ghz I-7, 16GB RAM, 750G 7200 RPM HDD, non-retina, 1680x1060 screen.
OS X 10.8.2

I noticed a week or so ago, that my MBP has started, on occasion, to waken slowly. It is as if it is loading a lot of stuff- long enough that it starts to wake up but takes long enough that it will blank the screen again before it becomes functional and I can put in my password. Neither the mouse pointer nor the keyboard are responsive.

Once it awakens, it is just fine- no problems, no crashes, no change in performance.

Thoughts?
 

SDAVE

macrumors 68040
Jun 16, 2007
3,381
444
Nowhere
Might want to get rid of the sleep image and disable it.

Remember, everytime you close, it needs to update a huge 16-20GB file (since you have 16GB of RAM). When you open the lid it accesses the image as well.

My 2011 MBP (15") came with a 750GB HD and I updated the ram to 16GB and switched to an SSD. The resume time went from 5-10 seconds to 1 second. I erased the sleep image to save space as well.
 
Comment

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
Might want to get rid of the sleep image and disable it.

Remember, everytime you close, it needs to update a huge 16-20GB file (since you have 16GB of RAM). When you open the lid it accesses the image as well.

My 2011 MBP (15") came with a 750GB HD and I updated the ram to 16GB and switched to an SSD. The resume time went from 5-10 seconds to 1 second. I erased the sleep image to save space as well.

Sounds good. If I knew what to do, that is. LOL I have no idea what the sleep image is (though I suspect I know.) I also have no idea where to find it.

----------

pmset -g result:

Active Profiles:
Battery Power -1
AC Power -1*
Currently in use:
standbydelay 4200
standby 0
womp 1
halfdim 1
hibernatefile /var/vm/sleepimage
gpuswitch 2
sms 1
networkoversleep 0
disksleep 10
sleep 25
autopoweroffdelay 14400
hibernatemode 3
autopoweroff 1
ttyskeepawake 1
displaysleep 25
acwake 0
lidwake 1
 
Comment

kissmygrass

macrumors newbie
Nov 19, 2012
23
0
June 2012 MBP 2.6Ghz I-7, 16GB RAM, 750G 7200 RPM HDD, non-retina, 1680x1060 screen.
OS X 10.8.2

Did you install MacBook Air and MacBook Pro Update 2.0? (at the beginning of November)

You have standby 0, so in theory your MacBook should not go into deep sleep/hibernation after some time, only in case of low battery power. In theory, because the update I have mentioned messed up big time. Try increasing standbydelay (seconds) to significantly bigger value to prevent the switch.

There are some reports that switching to hibernatemode 0 and re-creating sleepimage file with restricted access helps, but my impression is that nothing is sure.
 
Comment

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
Yes, my software/firmware is up-to-date.

I'll try those suggestions and see how it goes for a few days. As I said, if there is a trend to when this happens, I have yet to discern it.
 
Comment

CausticPuppy

macrumors 65816
May 1, 2012
1,483
18
standbydelay 4200

This setting controls how long the system will remain asleep, in seconds, before going into "deep sleep", which means writing the contents of memory (all 16GB) to disk.

Once it's in deep sleep it takes longer to wake up because it has to read 16GB from your disk back into memory.

4200 seconds = 70 minutes. I set mine to 24 hours using:

sudo pmset -a standbydelay 86400

So now it wakes up instantly if it's been asleep less than 24 hours.
 
Comment

Moshe1010

macrumors 6502a
Jun 27, 2010
858
76
This setting controls how long the system will remain asleep, in seconds, before going into "deep sleep", which means writing the contents of memory (all 16GB) to disk.

Once it's in deep sleep it takes longer to wake up because it has to read 16GB from your disk back into memory.

4200 seconds = 70 minutes. I set mine to 24 hours using:

sudo pmset -a standbydelay 86400

So now it wakes up instantly if it's been asleep less than 24 hours.
Isn't it taking more battery that way?
 
Comment

Beachguy

macrumors 65816
Original poster
Nov 23, 2011
1,008
407
Florida, USA
Not sure about the battery thing, but it did the job. Since I made this change, I have not had one of the deep deep sleep issues.

Since my laptop is normally used plugged in, battery life isn't a real issue. I have an Air when I need portability.

----------

Oh- and many thanks to those who contributed suggestions and comments. Much appreciated, people!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.