MBP 2015 - Keyboard and trackpad not working

Discussion in 'MacBook Pro' started by milesdavis100, Dec 17, 2016.

  1. milesdavis100 macrumors newbie

    Joined:
    Nov 14, 2014
    #1
    Hi everyone,

    I am hoping someone has experienced this and can help.

    Yesterday the trackpad and keyboard on my 2015 13 MBP started to work intermitendtly , today they stopped working all together. At first, it seemed they both worked fine if I switched to a different user. Today, that is no longer the case. I am using a bluetooth keyboard and mouse .

    I tried :

    - SMC reset
    - Pram reset
    - reboots multiple times

    The keyboard keys are lit - however, it doesn't appear the caps lock light shifts to green when I press it .

    I'm running 10.10.5

    I'm curious if anyone has any idea what could be going on. I am currently doing a complete back-up and am thinking I may attempt to reinstall the OS .

    Is it possible this is a software problem? Does the keyboard light being on / caps lock indicate anything?

    Thank you for your assistance - MD100
     
  2. Daelos macrumors member

    Joined:
    Aug 3, 2008
    #2
    I'm having the same problem.

    Took it store today, where it was taken out back. They told me the keyboard/trackpad flex cable was not seated properly, that they reconnected it, and that it now worked. Well it did, for about 20 minutes of use.

    I've yet to diagnose the cause but the good thing is that I can use the keyboard and trackpad in Ubuntu. The bad news is that it doesn't work in any version of OS X from Yosemite up (clean installs), and the software i use is mac only. Oh, and talking with apple support: they don't have any idea yet what it could be either. Back to the store on Monday...
     
  3. milesdavis100 thread starter macrumors newbie

    Joined:
    Nov 14, 2014
    #3
    that doesn't sound very encouraging... have you had any other issues with USB , specifically USB 3 devices? I feel like it may be connected somehow. Did any of the clean installs help? I was planning on doing that to see if it helped

    thanks - MD100
     
  4. Daelos macrumors member

    Joined:
    Aug 3, 2008
    #4
    I don't have any USB 3 devices, but USB 2.0 has never caused any issues. Clean installs didn't work at all for me, but I'd recommend it - If you have to take it to a store, they may ask you if you have done that anyway. Plus it may work for you.

    I'm assuming it's a software problem, though the employees I spoke to today ruled that out saying it was hardware (well, except for the guy on the phone after telling him about Ubuntu). The only info I have is that they suspect it could be hardware or communication thing going on, and that they 'should definitely' be able to fix this. that and the erase and reinstall is the most in depth thing they can do on a software diagnostic level.
     
  5. Daelos macrumors member

    Joined:
    Aug 3, 2008
    #5
    Update: Apple can't tell me what the problem is. They've ordered in a load of parts and are taking the attitude of take it apart and replace bits until it works again, though they can't explain why it works in Ubuntu but not in any version of Mac OS (X) or any of their diagnostic stuff. I need this machine for work so will have to take it in in January. Or, as the employee told me: buy a new one(!)
     
  6. milesdavis100 thread starter macrumors newbie

    Joined:
    Nov 14, 2014
    #6
    That sucks :(

    I installed some updates and it went from frozen to working but still locking up . I ran diagnostic mode and it reported I had a minor battery issue ...

    Very strange . I still haven't done a clean install

    Does anyone know if it's possible for the connection to be jarred loose ?

     
  7. Daelos macrumors member

    Joined:
    Aug 3, 2008
    #7
    I believe it is. This was the initial diagnosis and fixed it for a short while. As the trackpad is connected to the keyboard, apparently its more commonly a trackpad issue though. Again, that it works outside Mac OS is curious. Do you still get feedback from the trackpad (does the haptic engine kick in when clicking)?
     
  8. Daelos macrumors member

    Joined:
    Aug 3, 2008
    #8
    Whilst running a build script in Python last night, the keyboard and trackpad came back (although force touch doesn't always work). The machine got rather hot, as it did when the previous 'fix' failed. I'm not sure if this is helpful to you, or if it indicates the problem may be caused by the battery. I'll still be taking this in for repair in the new year - of 3 MacbookPro's I've owned for work, two have now had keyboard/trackpad and screen issues (the antireflective coating is coming off of this one too).
     

Share This Page