MBP (2016) connection to wifi in sleep mode

Discussion in 'MacBook Pro' started by tomviolence, Nov 28, 2016.

  1. tomviolence, Nov 28, 2016
    Last edited: Nov 28, 2016

    tomviolence macrumors member

    Joined:
    Jan 16, 2012
    #1
    Noticing my friend’s new MBP 2016 (13" base NTB, obviously running macOS Sierra) stays connected to the wi-fi when in sleep mode. Given how Apple is pushing all of us to permanent wireless connectivity I would suspect this kind of behaviour has become standard practice. However, wondering if it were possible to get it to disconnect from the wi-fi when in sleep mode.

    Already disabled, without effect:
    • Power Nap
    • Wake for network access

    Much obliged.

    EDIT:
    Noticing by looking at the connected wireless clients on AirPort Extreme (hours after the MBP has gone to sleep).
     
  2. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #2
    I doubt your friend's Mac is in full sleep mode, if wifi is still connected. To my knowledge it isn't possible to be in full sleep mode and stay connected to wifi.

    Edited to add: Maybe he has the Mac in Power Nap mode, or just has the screen off.
     
  3. tomviolence thread starter macrumors member

    Joined:
    Jan 16, 2012
    #3
    The lid of the MBP is closed… I would think it to be in sleep mode.
     
  4. skids929 macrumors 6502a

    skids929

    Joined:
    Mar 24, 2011
    #4
    I have no proof of this but I want to say it stays connected temporarily just in case you open the lid soon after closing it, it's right there. Once it gets into the lock screen I am trying to figure out if it is still connected to wifi.
     
  5. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #5
    If "wake for network access" is checked in power settings, that can trigger wifi even in sleep mode. I forgot about that. If it isn't checked, the Mac can't be in full sleep mode and have wifi access.
     
  6. skids929 macrumors 6502a

    skids929

    Joined:
    Mar 24, 2011
    #6

    Whats the path to this setting? I am not finding it. thanks
     
  7. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #7
    System Preferences > Energy Saver
     
  8. skids929 macrumors 6502a

    skids929

    Joined:
    Mar 24, 2011
    #8

    found it thanks!
     
  9. tomviolence thread starter macrumors member

    Joined:
    Jan 16, 2012
    #9
    As stated in my op, turning off ‘Power Nap’ and ‘Wake for network access’ does not make a difference. Anyone else have suggestions? Thanks in advance.
     

Share This Page