MBP 2016 ethernet stop working after sleep

Discussion in 'MacBook Pro' started by maxsquared, Mar 7, 2017.

  1. maxsquared macrumors regular

    Joined:
    Jun 27, 2009
    #1
    Hey guys,

    I bought one of those USB-C ethernet adapters and connected my MBP 2016 with TB to use Ethernet connection, however, every time I put my computer to sleep, the ethernet adapter stops working and I have to unplug and plug it back in again to make it work again. Has anyone else experienced this? How can I make it work, as it's really annoying.

    Thanks,
     
  2. Zillion macrumors regular

    Zillion

    Joined:
    Jan 2, 2008
    Location:
    The Netherlands
    #2
    I have this too with an adapter which also has 3 USB ports. I wonder if for example a Belkin USB-C to Ethernet adapter would not have this problem.
     
  3. Sanpete macrumors 68020

    Joined:
    Nov 17, 2016
    Location:
    Utah
    #3
    Which adapter?
     
  4. Zillion macrumors regular

    Zillion

    Joined:
    Jan 2, 2008
    Location:
    The Netherlands
    #4
    I have an Aukey USB-C hub (3 USB, 1 ethernet).

    Does anyone NOT have this problem, loosing ethernet after sleep?
     
  5. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #5
    I don't. Works fine with both my TB1 dock as well as the Belkin USB-C ethernet adapter.
     
  6. pshifrin macrumors 6502

    pshifrin

    Joined:
    Mar 14, 2010
    #6
    The Belkin adaptor, which Apple sells, does not have this issue.
     
  7. maxsquared thread starter macrumors regular

    Joined:
    Jun 27, 2009
    #7
    Mine is Aukey 3 port usb c hub too. This could be an Aukey problem
     
  8. Zillion macrumors regular

    Zillion

    Joined:
    Jan 2, 2008
    Location:
    The Netherlands
    #8
    I have now the "LMP 8 Port USB-C mini", which seems to be exactly the same as the "Satechi Type-C Multi-Port Hub 4K Ethernet". This does NOT have this problem :)
     

Share This Page