MBP 2016 - LG 5k monitor and windows bootcamp problem

Discussion in 'Windows, Linux & Others on the Mac' started by Finurliig, Jan 20, 2017.

  1. Finurliig, Jan 20, 2017
    Last edited: Jan 20, 2017

    Finurliig macrumors member

    Joined:
    Jan 2, 2017
    Location:
    Sweden
    #1
    When I boot Windows 10 via bootcamp, I have experienced very erratic behaviour when I connect the 27'' 5k LG monitor to my 15'' MBP 2016, as follows:

    • Windows will crash outright: and reboot
    • No picture at all will show up on the LG display: and an error message, "USB device not recognized" will appear on the MBP display
    • I will get a picture on the LG display, but with max resolution 1280p
    • Sometimes the problem will only affect one of the thunderbolt 3 ports on the mac, sometimes all of them: i.e. I will get a picture if I connect the LG monitor to one of the ports, but not if I connect it to any of the others
    • The display works flawlesssly during a windows session: with 4k resolution, as it should.
    I know this is not a hardware or cable issue: since the monitor is working perfectly in MacOS. Windows is updated. Have tried a number of reboots. Reinstalling the AMD drivers in Windows has had no effect on the problem. That could indicate that Windows in itself is the root of the problem. It seems to handle this (new) type of connection poorly?

    Has anyone else experienced anything similar, and is there a solution to this problem?
     
  2. mhd2100 macrumors member

    mhd2100

    Joined:
    Nov 3, 2016
    #2
    Did using my unofficial amd drivers fix this issue for you?
     
  3. Finurliig thread starter macrumors member

    Joined:
    Jan 2, 2017
    Location:
    Sweden
    #3
    Well, if you are the guy behind www.bootcampdrivers.com, they seem to have: I wrote a post about that on the apple forums:
    https://discussions.apple.com/message/31284018#31284018

    During the last windows session, I got some funny messages about "Link error", but apart from that, everything worked as it should.
     

Share This Page