MBP 2017 Unexplained slow write speeds to flash drives

Discussion in 'Mac Basics and Help' started by Mr West, Mar 16, 2018.

  1. Mr West macrumors member

    Mr West

    Joined:
    Apr 9, 2012
    #1
    Hey guys

    Can anyone help me with the problem I'm currently facing:

    My Macbook Pro (2017) writes extremely slow to USB flash drives.
    I have tried 3 different USB 3.0 flash drives (only one encrypted) and they all drop down to less than 30mb/s. However using the same flash drives on a Surface goes way faster (normal USB 3.0 speed).

    As adapter I'm using an Anker USB-C to USB 3.1 Adapter. I have no idea what is suddenly causing this. I also tried different ports. Everything else on the macbook works just fine.

    Should I take it back to the Apple store?

    Thanks in advance!
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    I'll guess that the slowdown has -something- to do with the "interaction" between the flash drive itself and the adapter.

    It might be worth trying the flash drive WITHOUT the adapter on a MacBook that still has USB-a type ports. Perhaps the 2015 15" MacBook Pro? (if the Apple store has one on display)...
     
  3. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #3
    The theoretical maximum rate for USB 3.0 is 60MB/s, so 30MB/s in real world use isn’t so bad. How are you measuring transfer speed? Could the tools you’re using be confusing megabytes per second and megabits per second? How much time does it take to transfer the same data from each machine.
     
  4. Mr West, Mar 16, 2018
    Last edited: Mar 16, 2018

    Mr West thread starter macrumors member

    Mr West

    Joined:
    Apr 9, 2012
    #4
    I'll give it a try. Sunday I'm meeting a friend who has a different adapter, so I can try to filter that one too.
    --- Post Merged, Mar 16, 2018 ---
    I downloaded a tool, but only after my frustration, I'll run it again later to have exact measurements. However it does take more than 10 minutes for a gigabyte to transfer from computer to drive. The same flash drive on my Surface from work is blazing fast. So a part from the exact figures, it is definitely way slower than it should be.
     
  5. Mr West thread starter macrumors member

    Mr West

    Joined:
    Apr 9, 2012
    #5
    Update: Just tried with a different cable; same problem.
    Will take it to the Apple store :(.
     
  6. Axam macrumors newbie

    Joined:
    Nov 14, 2016
    #6
    You're wrong. Theoretical speed for USB 2.0 is 60 MB/s. For USB 3.0 Gen 1 it is 625MB/s, for USB 3.0 Gen 2 is 1250MB/s. So 60MB/s is awful speed. I can get 400-450 MB/s with USB 3.0 Gen 2 enclosure and SSD drive. SSD drive speed rated to 500MB/s.
    --- Post Merged, Mar 18, 2018 ---
    First of all check in System Information your drive speed. If it is 480Mbit/s, then your adapter is an issue.
     
  7. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #7
    Something else to keep in mind is that USB flashdrives -- whether they be USB3 or not -- seldom run "as fast as the advertised speeds".

    It's just the way things are...
     

Share This Page

6 March 16, 2018