mbp 2018 won't sleep, battery drains in hours

Discussion in 'MacBook Pro' started by Sonic, Oct 21, 2018.

  1. Sonic macrumors regular

    Joined:
    Aug 4, 2006
    #1
    hi there. my new machine which has given be nothing but issues has a new issue. it won't sleep at all.

    filevault, powernap, wake for ethernet access disabled. when i come to it in the morning, the screen is on if on power adaptor. if on battery, closing the lid will see the battery fully drain in 5 hours or so. it went from 100% to 1% in about 4 hours yesterday, while in its case.

    this machine has given me nothing but stress. does anyone have any suggestions?

    (recently also been getting a lot of full crashes in various bits of software with CoreGraphics being the reported cause - i'm not sure if this is related.)

    having read some other similar threads, i typed "pmset -g assertions" into terminal and received:

    pid 180(coreaudiod): [0x0007fd4200019925] 00:15:27 PreventUserIdleSystemSleep named: "com.apple.audio.BuiltInSpeakerDevice.context.preventuseridlesleep"

    Created for PID: 36361.

    pid 94(hidd): [0x0007fd2600099bb5] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4295289019.3"

    Timeout will fire in 600 secs Action=TimeoutActionRelease

    Kernel Assertions: 0x4=USB

    id=615 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.01100000 owner=4-Port USB 3.0 Hub

    id=617 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14100000 owner=4-Port USB 2.0 Hub

    id=619 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14140000 owner=PLAYSTATION(R)3 Controller

    id=620 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14130000 owner=PLAYSTATION(R)3 Controller

    id=621 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14110000 owner=IOUSBHostDevice

    id=624 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14112000 owner=iLok

    id=625 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14111200 owner=eLicenser

    id=626 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14111300 owner=Keyboard Hub

    id=628 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14111400 owner=Launchpad Pro

    id=629 level=255 0x4=USB mod=01/01/1970, 01:00 description=com.apple.usb.externaldevice.14111310 owner=Microsoft USB Optical Mouse

    Idle sleep preventers: IODisplayWrangler
     
  2. lavrishevo macrumors 68000

    lavrishevo

    Joined:
    Jan 9, 2007
    Location:
    NJ
    #2
    Did you try a pram reset? You might also want to save all your data, boot into recovery, and do a fresh install of the OS.
     
  3. Sonic thread starter macrumors regular

    Joined:
    Aug 4, 2006
    #3
    i have gone through those steps, and already reinstalled everything due to fan noise and panics, but it's been a few weeks where it's mostly worked ok, besides things like the sleep issue, the random loss of copy and paste, the audio glitches and pops, small graphical glitches, etc.

    it just seems like there's no end to the little frustrations with this computer. i will do another pram reset and test it out tonight, thanks for the suggestion.
     
  4. techtim89 macrumors newbie

    Joined:
    Sep 24, 2012
    Location:
    Ohio
    #4
    Sonic, did you have any luck recently with this issue? I too have been plagued with the new 2018 Macbook Pro with touch bar not sleeping issue. I went so far as to take it into the Apple Genius Bar and they didn't have any answers. Ran a slew of hardware tests and it came back fine. I bought the system off of B&H photo video and sent my original one back and they sent me a new one. Having the same issue with it too! Has to be a system/macOS issue. It's so irritating! I store my system in a laptop backpack and not only does the system battery drain incredibly fast it becomes insanely hot! When I wake it the fans blow full and I feel like the system is taking off.

    I've recently done a lot more research and have been running "pmset -g assertions" and have found that handoff and any type of app that uses audio flags a "PreventUserIdleSystemSleep". I've disable handoff and I'm testing it now. Any updates form you? Thanks!
     
  5. techtim89 macrumors newbie

    Joined:
    Sep 24, 2012
    Location:
    Ohio
    #5
    So I've been digging into this issue as it's been driving me crazy when I go to use my system and it's either dead or close to being dead. I ended up disabling "Find My Mac" in the iCloud settings. This has in my case SOLVED my issue! Give it a try for anyone plagued with this issue as well.
     
  6. Howard2k macrumors 68020

    Howard2k

    Joined:
    Mar 10, 2016
    #6

    Doesn't solve the issue though really, it just means you lost the ability to use Find My Mac.

    Sleep worked on Sierra with FMM enabled. It was worse on High Sierra. Then on Mojave it's now pretty useless.
     
  7. _Kiki_ macrumors 6502a

    Joined:
    Aug 13, 2017
    #7
    quality of Apple software is falling down, every new OS has more bugs than previous
     
  8. Howard2k macrumors 68020

    Howard2k

    Joined:
    Mar 10, 2016
    #8
    I find Mojave rock solid. Night and day improvement over High Sierra. If Sleep was usable it would be a huge win for me.
     
  9. _Kiki_, Nov 11, 2018
    Last edited: Nov 11, 2018

    _Kiki_ macrumors 6502a

    Joined:
    Aug 13, 2017
    #9
    I don't use currently Find my Mac, so I have 1%-2% battery drop during sleep for every 24h (MBP 15 TB 2016)

    on my iMac Retina High Sierra crashed recently, about 3 days after some minor update, so I updated using Internet Recovery to Mojave, all important data was saved during the process
     

Share This Page

8 October 21, 2018