Resolved MBP 2019 External HDD Problem

Discussion in 'MacBook Pro' started by Omegasz, Aug 11, 2019.

  1. Omegasz macrumors newbie

    Joined:
    Aug 11, 2019
    Location:
    Bulgaria
    #1
    So I got my base model MBP 2019 and chose to buy an external HDD to have more space. I tested the HDD on my windows computer and it is working fine. The HDD is with USB 3.1. I also bought a USB-C Hub but I kind of cheeped out on it. It does say it's usb-c to usb 3.1 however. Now the problem is whenever I try to copy any files on the HDD from Mac it takes way too long. For example for 11 GB it says around 2 hours when on my PC it did 16 GB in literally a few minutes. The HDD is formatted to exFAT (thought I tried it with all possible formats). Also there is no problem copying files FROM the HDD to the Mac just from Mac to HDD.

    Side note: uTorrent also doesn't let me download directly onto the HDD by saying it doesn't have enough permissions to right on it.
     
  2. poorcody macrumors 6502a

    poorcody

    Joined:
    Jul 23, 2013
    #2
    First thing I would check is whether the drive is connecting as USB 3 or USB 2 (USB 2 seems more consistent with the speeds you are seeing).

    Just open the System Report on your Mac (Apple Menu -> About This Mac -> "System Report..." button). Under Hardware -> USB on the left pane, see if the drive is listed under USB 2.0 Bus or USB 3.0 Bus.
     
  3. DubCity macrumors newbie

    Joined:
    Aug 8, 2019
    #3
    What size is your MacBook internal SSD?
    Which external HDD did you buy?
    Which USB C Hub did you buy?
     
  4. Omegasz thread starter macrumors newbie

    Joined:
    Aug 11, 2019
    Location:
    Bulgaria
    #4
    Internal is 128 GB, External is 1TB SP ARMOR60, USB C Hub is Hama USB 3.1 Type-C Hub 1:4
    --- Post Merged, Aug 12, 2019 ---
    Both the hub and the hard drive are linked under the USB 3.1 Bus but it says that one is the HDD 3.0 and the other says it is a USB 2.0 HUB. So is it possible that the hub was falsely advertised as 3.1?
     
  5. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    1. Download AJA System Test from here:
    https://www.aja.com/products/aja-system-test

    2. DISCONNECT ALL DEVICES from the MacBook

    3. Connect the problem drive DIRECTLY to the MacBook

    4. Run AJA System Test on the drive.

    5. Post the results here.

    Could be...
    - bad cable
    - bad hub
    - SLOW hub
     
  6. poorcody macrumors 6502a

    poorcody

    Joined:
    Jul 23, 2013
    #6
    Not quite sure what you are saying there -- it certainly is possible for the hub to be listed under both USB 2 and 3 because they generally provide backwards compatibility. The important thing is which version the drive is listed under.

    It's possible the hub is really 3.1 but has some compatibility issue with your Mac. A few steps I would take:
    • Get a straight USB-C to USB-A adapter and try the drive that way, just to eliminate the hub. The overpriced Apple one is the safest bet from a compatibility point of view.
    • If you haven't tried already, disconnect any thing else plugged into the hub, and also try it with the other USB-C ports, especially the ones on the opposite side of the Mac if you have four of them. Power off the computer and restart it when doing this.
    • Also probably worth running Disk Utility on the disk just to make sure it doesn't find anything wrong.
    • Last but not least, you may want to try a different cable from the hub to the drive. Occasionally they can be a problem, especially at higher speeds.
     
  7. Omegasz thread starter macrumors newbie

    Joined:
    Aug 11, 2019
    Location:
    Bulgaria
    #7
    Okay so I'm not sure how to change the status to resolved but long story short the problem was the hub and once I changed it everything is working fine now. Thank you all very much for your help!
     

Share This Page

6 August 11, 2019