MBP 7.1 Battery Charging Issue on Mavericks

Discussion in 'MacBook Pro' started by Ofirbe, Feb 15, 2014.

  1. Ofirbe macrumors newbie

    Joined:
    Feb 15, 2014
    #1
    Hi,

    I'll start with apologize, I am new to this forum and I hope I'm not breaking any rules.

    So I installed mavericks on my MBP (mid 2010 13") on an SSD drive (Kingston) at first and before getting the apple efi update my magsafe charger was doing a great job and charged my battery to full and indicates with a green light.

    Now my battery is not charging, the charger indicates green light as its full even though it's not, i tried almost any post on the net and in this great forum:

    * I reset the SMC (Shift + control + option and using rEFIit) - not helped.
    * I tried to reset the NVRAM and PRAM - not helped.
    * I opened the MBP cover and removed the battery, clicked the power button for few seconds and re-attached the battery again - not helped but its brought back the battery icon and % capacity to the bar that's gone after SMC reset.
    * Strange thing that happening when I am resetting the SMC:
    when I'm releasing the buttons all together and short clicking the power button right away I'm getting the charger orange light (the MBP is still not running and the battery still not charged), if I'll click again on the power button and start the MBP and the charger will show the green light again.
    i uploaded a video showing it:
    http://www.youtube.com/watch?v=3151oSzTYss
    * i rade a post here saying to remove the battery and by using rEFIt to flash again the smc efi file, i tried it but when i running the -reset 1 command the MBP shutdown and i need several power button clicking to start it again, that goes the same for running the -LoadApp -norestart command.
    when i'm running the command without removing the battery the MBP is not shutting down and i can see the commands are running but again it is not helping and my battery sefused to be charged :(

    some tech info:
    My battery cycles are 64

    Any ideas?
     
  2. Macman45, Feb 15, 2014
    Last edited: Feb 15, 2014

    Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #2
    The behaviour of the lights during an SMC reset is normal...it could be coincidence but it sounds to me like your charger may have died. I'd borrow one and see if the battery charges then...it's annoying when things like this happen but the charger sounds like the culprit to me.
     
  3. Ofirbe thread starter macrumors newbie

    Joined:
    Feb 15, 2014
    #3
    Thanks for your response, i'll try it and update with a result.
     
  4. Ofirbe thread starter macrumors newbie

    Joined:
    Feb 15, 2014
    #4
    update:
    I tried another charger as suggested above and seems like i'm facing the same issue with both chargers, i used mine to charge another MBP and it worked fine.

    another thing i found that if my MBP is under SMC mode (fan in full speed and battery not recognise i am able to charge the battery even when the computer is shutdown) after exiting the SMC mode i can see the battery icon and its capacity.

    weird stuff :( anyone faced this issue or can think of a workaround ?
    good news is that i am able to charge the battery bad news is that it must be on SMC mode with no indications it is working.
     

Share This Page