MBP, AirPort won't stay connected

Discussion in 'MacBook Pro' started by msizzle64, May 11, 2010.

  1. msizzle64 macrumors 6502

    msizzle64

    Joined:
    Apr 8, 2007
    Location:
    Los Angeles, CA
    #1
    I have a fairly new 17" Unibody MacBook Pro, and recently my AirPort signal cuts off after about 30 minutes. I could just be on Facebook, and I will loose the signal after 30 minutes, and then i got to reselect my network. It becomes very annoying if when I try uploading videos to YouTube, having to start uploading all over about 3 times. I took it to the Genius Bar on Saturday, and they couldn't diagnose the problem, and they said they have to send it out to depot, but i can't afford being without my machine till June. I've tried restoring the default settings on my AirPort base station, but that didn't effect the problem. Could there be a problem with the AirPort card in my machine? If not, could there be other things i can try?

    Please Help,

    Thanks
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Have you tried any other wireless device on your network? I'd do that to see if it has the same behavior.
     
  3. msizzle64 thread starter macrumors 6502

    msizzle64

    Joined:
    Apr 8, 2007
    Location:
    Los Angeles, CA
    #3
    My brothers MacBook and my iPad stays connected just fine.
     
  4. xaquaticx macrumors regular

    Joined:
    Feb 6, 2010
    #4
    Welcome to a MacBook Pro. Wireless is much, much worse than on a MacBook or any other Apple product. You paid more and got less. But that metal case looks so cool! :rolleyes::rolleyes::rolleyes:

    I'm sending mine back because of this and if the replacement does the same thing I'm swapping for a macBook.
     

Share This Page