MBP Audio Out problems

Pants Dragon

macrumors regular
Original poster
Nov 8, 2006
212
0
I have a 17 inch SR MBP which I bought just after the refresh, and today I got a strange problem. While I'm at my desk, I use external speakers to listen to music. When I leave my desk I simply unplug the speakers and the music starts playing out of the laptops built-in speakers. However, today when I unplugged it, the speakers on the laptop did not output any sound, and a red LED I had no idea about came on inside the audio out port as if it were asking me to put the cord back in. The external speakers still work, but when I unplug them, I get no sound output from my built-in speakers EXCEPT when I reboot, I get the chime. Also, it will not let me adjust the volume with the speakers unplugged. not that the volume would matter, since it's not outputting any sound anyway.

Has anybody had this problem, and does anybody know how to fix it?
 

uwguy

macrumors newbie
Jul 15, 2007
23
0
I havn't had that specific problem, but the red light indicates that your computer is trying to output digital audio data through an optical cable. When in this mode it is not possible to change the volume level on the computer. I'm not sure what the fix would be, but hopefully knowing the computer is trying to output digital data will help in the search for a solution.
 

kolax

macrumors G3
Mar 20, 2007
9,188
115
There is a sensor which determines if it is headphones or an optical cable, and sometimes it can be dodgy.

Plugging in the headphones then removing them again sometimes works, otherwise prodding it with a paperclip has apparently also worked if your output is locked on optical.
 

Pants Dragon

macrumors regular
Original poster
Nov 8, 2006
212
0
Well I've tried poking it with a paper clip and the speaker cord, but it still isn't working... Any other suggestions?
EDIT: Scratch that, I finally got it with a paper clip. Thanks for the suggestion!
 

kolax

macrumors G3
Mar 20, 2007
9,188
115
Sounds like your audio output has switched to digital optical out.

Go to the Audio section of your System preferences - select the 'Output' Tab
change it from digital output.

Don't go sticking anything in the socket - always a bad idea ;)
Can't do that im afraid - there isn't a user option to select the output, OSX determines it for you based on what the sensor thinks is plugged in.

Poking around seems the only fix for now - been mentioned a few times here.
 

Pants Dragon

macrumors regular
Original poster
Nov 8, 2006
212
0
Yeah, checking system prefs was the first thing I did. But OS X has too much faith in its sensors to let you say it's wrong.:p
 

keenkreations

macrumors regular
May 20, 2005
122
5
Ha. Happened to me one time when I was making a presentation and using the sound output. Also had to mess around the sensor. Glad you got it to work!
 

dcazmere

macrumors newbie
Sep 3, 2007
1
0
anybody down with me to march into apple headquarters?????

Apple Techs Claim To Know Nothing About The Problem So Many Of Us Are Having With The Digital Out And Our Inability To Override The System Prefs For Output Sounds. I Feel If Enough People Walk Into Apple And Insist On Having This Issue Addressed We My Get Results. I Have Been Told On More Than One Occassion That A Tech Would Contact Me With Advise/ No Response! Goning On 2 Months With No Internal Speakers I Really Need This Issue To Be Resolved! Anbody Down To Make A Statement!!??!!??