MBP audio through HDMI (Starcraft 2)

Discussion in 'MacBook Pro' started by AbjectEvolution, Jul 28, 2010.

  1. AbjectEvolution macrumors 6502

    Joined:
    Jun 14, 2009
    #1
    I have the mini display to DVI adapter and then a DVI to HDMI adapter which then plugs into an HDMI cable that plugs into my home theater receiver. I get video on my TV, but I do not hear sound. Is this because I'm going from mini display to DVI first and that DVI doesn't carry sound... or is there some setting I need to turn on in order to send audio? Thanks.
     
  2. AbjectEvolution thread starter macrumors 6502

    Joined:
    Jun 14, 2009
    #2
    Also, how do I make my TV the only display so that it doesn't also send an image to my laptop screen? I went to make the resolution 1080p but it is mirrored to my laptop display and so it went all weird and the buttons were off in the Starcraft menu.
     
  3. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #3
    You need a separate connection; either directly connect via usb audio or through the mac's speaker connection.
     
  4. AbjectEvolution thread starter macrumors 6502

    Joined:
    Jun 14, 2009
    #4
    I read that the new MBPs could transmit audio over the mini display port though. Was that wrong?

    What about my displays? How can I make the secondary display the default and turn off the laptop display?
     
  5. bhattsan macrumors member

    Joined:
    Jun 16, 2010
    #5
    You would need a direct mini display port to hdmi cable to do that. Correct me if I'm wrong, but since you are first converting to dvi, it cuts out the audio, so that doesn't make it over to the hdmi connector. Hope that helps.
     
  6. dr. shdw macrumors 6502a

    Joined:
    Aug 27, 2008
    #6
    You need to get a straight MDP->HDMI thats audio compatible.

    Turn off mirroring.
     
  7. Discaciate macrumors member

    Discaciate

    Joined:
    Apr 28, 2010
    #7
  8. AbjectEvolution thread starter macrumors 6502

    Joined:
    Jun 14, 2009
    #8
    Won't turning of mirroring just make the MPB screen the default for the game?

    And thanks for the link to the adapter, I'll get it!
     
  9. sn0warmy macrumors 6502a

    sn0warmy

    Joined:
    Mar 26, 2009
    Location:
    Denver, CO
    #9
    Correct.

    Also correct.
     
  10. dr. shdw macrumors 6502a

    Joined:
    Aug 27, 2008
    #10
  11. dr. shdw macrumors 6502a

    Joined:
    Aug 27, 2008
    #11
    Make the TV your main screen.
     
  12. jclardy macrumors 68040

    jclardy

    Joined:
    Oct 6, 2008
    #12
    By dragging the menu bar to the TV display in system preferences. Just in case you didn't know how.
     
  13. Discaciate macrumors member

    Discaciate

    Joined:
    Apr 28, 2010
    #13

Share This Page