MBP Battery Is Not Charging after 10.9.2

Discussion in 'OS X Mavericks (10.9)' started by splizaat, Mar 5, 2014.

  1. splizaat macrumors member

    Joined:
    Jun 30, 2010
    Location:
    Oregon
    #1
    Hey guys...apple forum has proved unhelpful.

    Ever since 10.9.2, my MBP won't charge when plugged into my thunderbolt display power cord w/ magsafe 2 converter. It recognizes that it's plugged in, but states "Battery Is Not Charging" I will add that it's charged fine on the same cord for the last year, until I upgraded to latest update.

    BUT when plugged into a standard charger (like the one it came with), it charges perfect every time.

    This is a new issue since 10.9.2 and is consistent no matter which charger I use that has a magsafe 2 converter on it. If the charger is magsafe2, it works fine. We've reset SMC twice, reset PRAM....nothing working.

    Apple nerd bar plugged in an Ethernet diagnostic utility and it all checked out including mainboard and battery. We used different mag safe 2 converters and same result everytime. Until we plugged into a charger that came magsafe2 from factory, then it works fine. When I left, they tried telling me that my motherboard is going out (HAH!)

    Is anyone else experiencing this? It never happened until 10.9.2

    Matt
     
  2. bwillwall macrumors 6502a

    bwillwall

    Joined:
    Dec 24, 2009
    #2
    0_0

    My MacBook Pro Retina won't charge at all! I started having the problem the day the update came out. But I didn't install it until several days later so I didn't think that could be the issue...but now it just seems like too much of a coincidence! I have reset the SMC, restarted to bootcamp, tried another charger, tested my hardware with Apple Hardware Test, all to no avail. I finally replaced the MagSafe port myself because I was told that was likely the issue but it still hasn't fixed the problem.

    15" 2012 Retina MBP here.
     
  3. pjiricka macrumors newbie

    Joined:
    Mar 15, 2014
    #3
    I also see a similar problem. Charging works intermittently, and I have to position the cable very carefully to a specific position to make it charge. I have the "late 2008" 13" MacBook.
     
  4. SolRayz macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #4
    I have a "Service Battery" suddenly after the update.
     
  5. HuntingPudel macrumors member

    Joined:
    Feb 23, 2014
    Location:
    California
    #5
    I had a problem with charging using the original charger after upgrading my 2009 MBP to 10.9.0. In my case, I removed the bottom cover, then removed the battery and cleaned the contacts and reinstalled. It works OK now. Obviously, this probably isn't the issue that you're experiencing since yours will charge using a MagSafe power supply. I'm wondering if there's some sort of issue similar to the iOS/Lightning connector issue.

    The only problem with my MBP now is that it only has 68% of its useful capacity. It had over 80% prior to the upgrade. I'm not sure if the software reporting services are changed or what. Hasn't changed since upgrading to 10.9.1 and 10.9.2.
     

Share This Page