MBP Battery losing its Charge

Discussion in 'MacBook Pro' started by ShStylo, Jun 25, 2007.

  1. ShStylo macrumors member

    Jun 6, 2007
    Hey Guys...

    I've had my SR MBP for about 2 weeks now (ordered it when it first came out) and it seems to me that the battery's starting to die on me.

    First of all my Battery Health is 98% in iStat and 100% in CoconutBattery and I have noticed some others had that problem as well but seems to be normal I guess? Anyways before I begin, I have calibrated the battery twice so should not be the problem there.

    So after 2 weeks of plugging the MBP in, sometimes I unplug the AC adaptor when I go to bed but usually I leave it plugged in as I don't move my MBP around alot. The Battery Charge used to be 100% when I first calibrated it but is now going closer to 95%. I know that the charger won't charge anything above 95% to prevent overcharging but is it normal for the battery to lose 5% charge even though it is plugged in?

    Thanks for the advise everyone and could it be because I leave it plugged in when the MBP is turned off? Should I always be unplugging the AC when I go to bed? Thanks everyone! :D
  2. eenu macrumors 65816


    Aug 11, 2006
    Manchester, UK
    doesnt sound great...... try reseting the SMC and then re calibrate
  3. ShStylo thread starter macrumors member

    Jun 6, 2007
    hmmm that sounds a bit dangerous doesn't it?

    Has anyone else experienced this or is it just me? Also if the battery charge doesnt seem to ever drop below 95% should I still worry Eenu?
  4. miniConvert macrumors 68040


    Mar 4, 2006
    Kent, UK - the 'Garden of England'.
    I wouldn't worry yet, no. If something becomes obviously wrong with your battery then I doubt you'll have a problem getting Apple to replace it anyway.
  5. ShStylo thread starter macrumors member

    Jun 6, 2007
  6. zanlyons macrumors newbie

    Jun 6, 2007
    The same thing's happening with mine.
    I've reset the SMC and Calibarated but no change.
    The genius guy at the Apple Store said it's nothing to worry about.
    I noticed quite a few of the instore machines having the same issue as well, I'm still a bit nervous about it though.

Share This Page